summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMusikolo2018-11-26 21:53:25 -0600
committerMusikolo2018-11-26 21:53:25 -0600
commitb0e16f0493c3fc24d61c7b8621400fd738c14b51 (patch)
tree29058cf0e5fa8279d934908a86183051c4f03fc9
parent6a9bc16d895fe9682e026d4fe90a86dd6bc7d6d9 (diff)
downloadaur-b0e16f0493c3fc24d61c7b8621400fd738c14b51.tar.gz
Upgrade to version 0.2.5
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b07f0c8019cc..dc1957994b14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jul 5 05:30:07 UTC 2018
+# Tue Nov 27 03:50:58 UTC 2018
pkgbase = stsauth
pkgdesc = CLI tool for fetching AWS tokens. Creates a temporary AWS_ACCESS_KEY_ID and AWS_SECRET_ACCESS_KEY that can be used with cli tools such as awscli, ansible, terraform and more.
- pkgver = 0.2.0
+ pkgver = 0.2.5
pkgrel = 1
url = https://github.com/cshamrick/stsauth
arch = any
@@ -21,6 +21,8 @@ pkgbase = stsauth
depends = python2-configparser
depends = python-requests
depends = python-requests-ntlm
+ depends = python-click-log
+ depends = python-cryptography
source = git+https://github.com/cshamrick/stsauth.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6b63dca9a65f..f409259e1071 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer Musikolo <musikolo {at} hotmail [dot] com>
pkgname=stsauth
-pkgver=0.2.0
+pkgver=0.2.5
pkgdesc="CLI tool for fetching AWS tokens. Creates a temporary AWS_ACCESS_KEY_ID and AWS_SECRET_ACCESS_KEY that can be used with cli tools such as awscli, ansible, terraform and more."
pkgrel=1
arch=(any)
url="https://github.com/cshamrick/stsauth"
license=(MIT)
makedepends=(aws-cli python-pip python-boto3 python-beautifulsoup4 python-click python2-configparser python-requests python-requests-ntlm)
-depends=(python-boto3 python-beautifulsoup4 python-click python2-configparser python-requests python-requests-ntlm)
+depends=(python-boto3 python-beautifulsoup4 python-click python2-configparser python-requests python-requests-ntlm python-click-log python-cryptography)
options=()
source=("git+https://github.com/cshamrick/${pkgname}.git")
md5sums=('SKIP')
package() {
mkdir -p "${pkgdir}"
- pip install --root="${pkgdir}" ${pkgname}==${pkgver} --no-warn-script-location
+ pip install --root="${pkgdir}" ${pkgname}==${pkgver} --no-warn-script-location --no-deps
}