summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrhun Parmaksız2024-03-26 17:15:15 +0300
committerOrhun Parmaksız2024-03-26 17:15:15 +0300
commitd45b9068ea19de65b0b54524db104c9cff5e0a50 (patch)
tree26d6431329aefb633f3c4aef8b74f57436cf8d5a
downloadaur-d45b9068ea19de65b0b54524db104c9cff5e0a50.tar.gz
Initial upload: stu 0.4.1-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD41
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3210b1f810b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = stu
+ pkgdesc = TUI for AWS S3
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/lusingander/stu
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ depends = gcc-libs
+ options = !lto
+ source = stu-0.4.1.tar.gz::https://github.com/lusingander/stu/archive/v0.4.1.tar.gz
+ sha512sums = 8200ef4acbb5cf62e37243ff92155a8efba47edfd712fc1c4847362dee34531684fb4fec0bce37037e57aad2c548c83905760dd30eb88c770734cecf27715e9e
+
+pkgname = stu
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9aa4ff1b7a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=stu
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="TUI for AWS S3"
+arch=('x86_64')
+url="https://github.com/lusingander/stu"
+license=('MIT')
+depends=('gcc-libs')
+makedepends=('cargo')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha512sums=('8200ef4acbb5cf62e37243ff92155a8efba47edfd712fc1c4847362dee34531684fb4fec0bce37037e57aad2c548c83905760dd30eb88c770734cecf27715e9e')
+options=('!lto')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --release --frozen
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}