summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordelitako2021-07-14 21:56:02 -0500
committerdelitako2021-07-14 21:56:02 -0500
commitf6b2eac04e05ea53b21a914b371377fbc9157f67 (patch)
treead19719c0931e03f1e55ef1f7259eb64107b5a9c
parentdf5154a4797faffdd9da83d6384ca0628f1a67cb (diff)
downloadaur-f6b2eac04e05ea53b21a914b371377fbc9157f67.tar.gz
Prevent loading quicklisp in final image
The previous release would include the temporary quicklisp install in the final image and create problems when trying to load new quicklisp packages later. This release patches stumpwm to load the packages without quicklisp. You will have to manually load your quicklisp setup script in your stumpwm config if you want to use quicklisp.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
-rw-r--r--load-ql-systems.patch14
3 files changed, 27 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5456e6a8fcb9..ea02416d6b9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = stumpwm-ql
pkgdesc = Stumpwm tiling window manager built with dependencies from quicklisp
pkgver = 20.11_2021_06_30
- pkgrel = 1
+ pkgrel = 2
url = https://stumpwm.github.io
arch = x86_64
license = GPL2
@@ -14,7 +14,9 @@ pkgbase = stumpwm-ql
options = !makeflags
source = stumpwm-ql-20.11.tar.gz::https://github.com/stumpwm/stumpwm/archive/refs/tags/20.11.tar.gz
source = stumpwm.desktop
+ source = load-ql-systems.patch
sha256sums = 8c9aaab9ad7cbc35e705c085e8661b20d88b84e750f7b1859e65a8b2f1ad562c
sha256sums = a297e9ded7854f06131b2440f46b5d903933e81aeabd31cb834e01672c6b2ac4
+ sha256sums = 5105db78328aed70e8d071ff02f35d10caa745803df8e71074a444cb7c6afefc
pkgname = stumpwm-ql
diff --git a/PKGBUILD b/PKGBUILD
index 88c026df4f52..a05fbef48220 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=stumpwm-ql
_stumpver=20.11
_qlver=2021_06_30
pkgver="${_stumpver}_${_qlver}"
-pkgrel=1
+pkgrel=2
pkgdesc='Stumpwm tiling window manager built with dependencies from quicklisp'
arch=('x86_64')
url='https://stumpwm.github.io'
@@ -13,15 +13,20 @@ makedepends=('quicklisp-bootstrap' 'sbcl')
provides=('stumpwm')
conflicts=('stumpwm' 'stumpwm-git')
source=("$pkgname-$_stumpver.tar.gz::https://github.com/stumpwm/stumpwm/archive/refs/tags/$_stumpver.tar.gz"
- stumpwm.desktop)
+ stumpwm.desktop load-ql-systems.patch)
sha256sums=('8c9aaab9ad7cbc35e705c085e8661b20d88b84e750f7b1859e65a8b2f1ad562c'
- 'a297e9ded7854f06131b2440f46b5d903933e81aeabd31cb834e01672c6b2ac4')
+ 'a297e9ded7854f06131b2440f46b5d903933e81aeabd31cb834e01672c6b2ac4'
+ '5105db78328aed70e8d071ff02f35d10caa745803df8e71074a444cb7c6afefc')
options=('!strip' '!makeflags')
+prepare() {
+ patch stumpwm-$_stumpver/load-stumpwm.lisp.in load-ql-systems.patch
+}
+
build() {
# Vars
disturl="http://beta.quicklisp.org/dist/quicklisp/${_qlver//_/-}/distinfo.txt"
- qlpath="$(pwd)/quicklisp"
+ qlpath=quicklisp
# Clear quicklisp directory if it exists
if [ -d "$qlpath" ]; then
@@ -37,15 +42,11 @@ build() {
--eval '(ql:quickload "alexandria")' \
--quit
- # Init file to load quicklisp
- echo "(load \"${qlpath}/setup.lisp\")" > quicklisp/.sbclrc
-
# Make
cd stumpwm-$_stumpver
./autogen.sh
./configure --prefix=/usr --with-module-dir=/usr/share/stumpwm/contrib
- # Trick SBCL into loading quicklisp
- HOME="${qlpath}" make
+ make
}
package() {
diff --git a/load-ql-systems.patch b/load-ql-systems.patch
new file mode 100644
index 000000000000..ad8992417de0
--- /dev/null
+++ b/load-ql-systems.patch
@@ -0,0 +1,14 @@
+9c9
+< '(:source-registry
+---
+> `(:source-registry
+11c11,13
+< :inherit-configuration))
+---
+> ;; Let asdf find the quicklisp systems that we installed
+> (:tree ,(merge-pathnames "../quicklisp/dists/quicklisp/software/"))
+> :ignore-inherited-configuration))
+13a16,18
+>
+> ;; Remove all source pathnames from the registry after load
+> (asdf:clear-source-registry)