summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2018-09-01 16:13:23 +0300
committerCaleb Maclennan2018-09-01 16:14:47 +0300
commitc237821c60c695edc9b90493305b2e70b4e9557f (patch)
tree5f7f882b23c7e44f136835cc24fa0f821433e648
parent4cb5ad28ed2cc249fe21c03e21216a67e7558192 (diff)
downloadaur-c237821c60c695edc9b90493305b2e70b4e9557f.tar.gz
Cleanup bash shell quoting using shellharden
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c435518be5a9..1867d11f35bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgver=0.97
pkgrel=5
pkgdesc='STUN Server and Client'
url='https://sourceforge.net/projects/stun/'
-source=("http://downloads.sourceforge.net/project/stun/stun/${pkgver}/${pkgname}-${pkgver}.tgz"
+source=("http://downloads.sourceforge.net/project/stun/stun/$pkgver/$pkgname-$pkgver.tgz"
'fix_non_i386.patch')
conflicts=('libnice')
arch=('x86_64')
@@ -14,18 +14,18 @@ sha256sums=('83e1bf9c21399244c5e8ad19789121a3537399d6523a887a5abc6187adcdb1d7'
'8c09a0acc8797bf8060ed84ca4e0d6ca242447ea8cbee6c28904a7056773030d')
prepare() {
- cd "${pkgname}"
- patch < ${srcdir}/fix_non_i386.patch
+ cd "$pkgname"
+ patch < "$srcdir/fix_non_i386.patch"
}
build() {
- cd "${pkgname}"
+ cd "$pkgname"
make all
}
package() {
- cd "${pkgname}"
- install -Ddm755 ${pkgdir}/usr/bin
- install -Dm0755 server ${pkgdir}/usr/bin/stund
- install -Dm0755 client ${pkgdir}/usr/bin/stunc
+ cd "$pkgname"
+ install -Ddm755 "$pkgdir/usr/bin"
+ install -Dm0755 server "$pkgdir/usr/bin/stund"
+ install -Dm0755 client "$pkgdir/usr/bin/stunc"
}