summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSo Wieso2016-11-01 22:20:59 +0900
committerSo Wieso2016-11-01 22:20:59 +0900
commitf677654dda28f837d11f8f4e5701de7c9a36e001 (patch)
tree4982a7682903e0fb43a6d53e70ff4d58f1490396
downloadaur-f677654dda28f837d11f8f4e5701de7c9a36e001.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rwxr-xr-xPKGBUILD27
-rw-r--r--stuntman.service14
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a1e2e2e160b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = stuntman
+ pkgdesc = STUN server and client
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = http://www.stunprotocol.org/
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = boost-libs
+ conflicts = stuntman-git
+ source = https://github.com/jselbie/stunserver/archive/version1.2.1.zip
+ sha256sums = 59c35de587699f4e8959b19d5d26173d27a9f4affe2b07b793dd95ac52508c53
+
+pkgname = stuntman
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..ae5ab7debdbf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# maintainer: so wieso <sowieso@dukun.de>
+pkgname=stuntman
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="STUN server and client"
+url="http://www.stunprotocol.org/"
+license=("Apache")
+arch=("i686" "x86_64")
+depends=()
+optdepends=()
+makedepends=("boost-libs")
+conflicts=("stuntman-git")
+source=("https://github.com/jselbie/stunserver/archive/version1.2.1.zip")
+sha256sums=("59c35de587699f4e8959b19d5d26173d27a9f4affe2b07b793dd95ac52508c53")
+
+build() {
+ cd "${srcdir}/stunserver-version${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/stunserver-version${pkgver}"
+ install -D -m0755 -t "$pkgdir/usr/bin/" stun{client,server}
+ install -D -m0644 -t "$pkgdir/usr/share/doc/${pkgname}" HISTORY README
+ install -D -m0644 <(./stunclient --help | gzip) "$pkgdir/usr/share/man/man1/stunclient.1.gz"
+ install -D -m0644 <(./stunserver --help | gzip) "$pkgdir/usr/share/man/man1/stunserver.1.gz"
+}
diff --git a/stuntman.service b/stuntman.service
new file mode 100644
index 000000000000..55fb22432e59
--- /dev/null
+++ b/stuntman.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Stuntman STUN-Server
+After=network.target
+
+[Service]
+Type=simple
+User=nobody
+Group=nobody
+ExecStart=/usr/bin/stunserver
+ExecStop=/usr/bin/killall --user nobody stunserver
+
+[Install]
+WantedBy=multi-user.target
+