summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMayorBender2019-06-18 22:55:03 -0400
committerMayorBender2019-06-18 23:01:17 -0400
commit2f8973e25d168dae29cb26bf3251bfa348379233 (patch)
tree4204ef8c4cd129036360f74f0604046cb1c68e83
parentcc401127e208ae058077fbf3e7fe7eac9c7f5c29 (diff)
downloadaur-2f8973e25d168dae29cb26bf3251bfa348379233.tar.gz
Added necessary python packages as dependencies.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD2
2 files changed, 14 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df0703f05480..8db1e5d421db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,10 +7,22 @@ pkgbase = style50
license = GPL
makedepends = python-setuptools
depends = python
+ depends = autopep8
+ depends = icdiff
+ depends = python-jsbeautifier
+ depends = python-magic-ahupp
+ depends = python-pycodestyle
+ depends = python-termcolor
optdepends = astyle: To style check C, C++, or Java code
source = https://files.pythonhosted.org/packages/source/s/style50/style50-2.6.4.tar.gz
- sha256sums = f97c7c46669030ff3da99bf17339b05f957469251ab92e34281cbd24753f22f0
+ sha256sums = 8bb68f0be72660411976ab1742c759845f981eefe0f21edb1533882a1833c8a0
pkgname = style50
depends = python
+ depends = autopep8
+ depends = icdiff
+ depends = python-jsbeautifier
+ depends = python-magic-ahupp
+ depends = python-pycodestyle
+ depends = python-termcolor
diff --git a/PKGBUILD b/PKGBUILD
index 0d8f32a4d9fd..97c46231a584 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgdesc="This is style50, with which code can be checked against the CS50 style
arch=('any')
url="https://github.com/cs50/style50"
license=('GPL')
-depends=('python')
+depends=('python' 'autopep8' 'icdiff' 'python-jsbeautifier' 'python-magic-ahupp' 'python-pycodestyle' 'python-termcolor')
makedepends=('python-setuptools')
optdepends=('astyle: To style check C, C++, or Java code')
source=(