summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStijn Seghers2017-04-09 11:05:12 +1200
committerStijn Seghers2017-04-09 11:05:12 +1200
commite6e3193a80c164e8a2fdaed0f3109feae965e7e4 (patch)
treee7a5d28af61c73cf7df0e3eceaf501f2f96ef024
downloadaur-e6e3193a80c164e8a2fdaed0f3109feae965e7e4.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a493082784b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = stylelint-config-standard
+ pkgdesc = The standard shareable config for stylelint
+ pkgver = 16.0.0
+ pkgrel = 1
+ url = https://github.com/stylelint/stylelint-config-standard
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ depends = stylelint
+ noextract = stylelint-config-standard-16.0.0.tgz
+ source = http://registry.npmjs.org/stylelint-config-standard/-/stylelint-config-standard-16.0.0.tgz
+ sha512sums = 576940e40d0811c601ddbc488c273e0c37ad97617f7a779f0197c256be2a30767f0a7b3df07f942a34035c1965f168262bf4be0025496d48c0ec5c98fd349e63
+
+pkgname = stylelint-config-standard
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27440576c401
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+
+# Maintainer: Stijn Seghers <stijnseghers at gmail dot com>
+
+pkgname=stylelint-config-standard
+pkgver=16.0.0
+pkgrel=1
+pkgdesc='The standard shareable config for stylelint'
+arch=('any')
+url='https://github.com/stylelint/stylelint-config-standard'
+license=('MIT')
+depends=('nodejs' 'stylelint')
+makedepends=('npm')
+source=("http://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz")
+noextract=("$pkgname-$pkgver.tgz")
+sha512sums=('576940e40d0811c601ddbc488c273e0c37ad97617f7a779f0197c256be2a30767f0a7b3df07f942a34035c1965f168262bf4be0025496d48c0ec5c98fd349e63')
+
+package() {
+ npm install -g --user root --prefix "$pkgdir/usr" "$srcdir/$pkgname-$pkgver.tgz"
+
+ rm -r "$pkgdir/usr/etc"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "../../../lib/node_modules/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}