summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStijn Seghers2018-06-24 19:42:52 +1200
committerStijn Seghers2018-06-24 19:43:01 +1200
commitff1d549239464f94d42b9f8b1b7c9dd4e1b1ed0d (patch)
treedc5ecd69ffc62ee267272e221cc7a61f5629cce2
parent8277c69c746281d3a18191cd97c992118a6e03b7 (diff)
downloadaur-ff1d549239464f94d42b9f8b1b7c9dd4e1b1ed0d.tar.gz
Version bump: 18.2.0
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD16
3 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f671fc1814e5..e5384451168c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = stylelint-config-standard
pkgdesc = The standard shareable config for stylelint
- pkgver = 18.0.0
+ pkgver = 18.2.0
pkgrel = 1
url = https://github.com/stylelint/stylelint-config-standard
arch = any
license = MIT
makedepends = npm
- depends = nodejs
- depends = stylelint
- noextract = stylelint-config-standard-18.0.0.tgz
- source = https://registry.npmjs.org/stylelint-config-standard/-/stylelint-config-standard-18.0.0.tgz
- sha512sums = 0e7baba8ec790ae9b2bb060fbee36b0671352e775e98593297c19091e1e1d6420bd75d4ccc1227329709bcbfa12a852b1db671e7d8afba893eb107a4385f8c22
+ noextract = stylelint-config-standard-18.2.0.tgz
+ source = https://registry.npmjs.org/stylelint-config-standard/-/stylelint-config-standard-18.2.0.tgz
+ sha512sums = d3bc744da488cef5e56ce8a8514e0e464088334ee4c88ba88e46d2542c8558d5605cc5d81df8674120a4aaefa81d625fdd80030273c65b3749e7737192827b44
pkgname = stylelint-config-standard
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fad592fca792
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.xz
+*.tgz
diff --git a/PKGBUILD b/PKGBUILD
index b978a136293f..1fbe7ca6b79c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,25 @@
# Maintainer: Stijn Seghers <stijnseghers at gmail dot com>
pkgname=stylelint-config-standard
-pkgver=18.0.0
+pkgver=18.2.0
pkgrel=1
pkgdesc='The standard shareable config for stylelint'
arch=('any')
url='https://github.com/stylelint/stylelint-config-standard'
license=('MIT')
-depends=('nodejs' 'stylelint')
+depends=()
makedepends=('npm')
source=("https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz")
noextract=("$pkgname-$pkgver.tgz")
-sha512sums=('0e7baba8ec790ae9b2bb060fbee36b0671352e775e98593297c19091e1e1d6420bd75d4ccc1227329709bcbfa12a852b1db671e7d8afba893eb107a4385f8c22')
+sha512sums=('d3bc744da488cef5e56ce8a8514e0e464088334ee4c88ba88e46d2542c8558d5605cc5d81df8674120a4aaefa81d625fdd80030273c65b3749e7737192827b44')
package() {
- npm install -g --user root --prefix "$pkgdir/usr" "$srcdir/$pkgname-$pkgver.tgz"
+ npm install -g --prefix "$pkgdir/usr" "$srcdir/$pkgname-$pkgver.tgz"
- rm -r "$pkgdir/usr/etc"
+ # For some odd reason, npm makes some directories world writeable D:
+ find "$pkgdir/usr" -type d -exec chmod 755 {} +
- install -d "$pkgdir/usr/share/licenses/$pkgname"
- ln -s "../../../lib/node_modules/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # Install license in the usual place
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ install -Dm644 "$_npmdir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}