summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPopa Ioan Alexandru2021-03-29 20:51:39 +0300
committerPopa Ioan Alexandru2021-03-29 20:51:39 +0300
commitaedf9f306341cd96126d8e83be56808f0aa25849 (patch)
treef9c056fd5edcee76b959181a65431aa3bde12079
downloadaur-aedf9f306341cd96126d8e83be56808f0aa25849.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f7a8fe25afb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = stylish-gtk-theme-git
+ pkgdesc = A flat Material Design theme for GTK 3, GTK 2 and Gnome-Shell
+ pkgver = 2020.09.12.53664fe
+ pkgrel = 1
+ url = https://github.com/vinceliuice/stylish-gtk-theme
+ arch = any
+ license = GPL3
+ makedepends = gtk3
+ makedepends = sassc
+ makedepends = git
+ optdepends = gtk-engine-murrine: for gtk2 themes
+ optdepends = gnome-themes-standard: for gtk2 themes
+ provides = stylish-gtk-theme
+ source = git+https://github.com/vinceliuice/stylish-gtk-theme.git
+ sha512sums = SKIP
+
+pkgname = stylish-gtk-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63ef44dfaf15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Popa Ioan Alexandru <alexioanpopa11@gmail.com>
+
+pkgname=stylish-gtk-theme-git
+pkgver=2020.09.12.53664fe
+pkgrel=1
+pkgdesc="A flat Material Design theme for GTK 3, GTK 2 and Gnome-Shell"
+arch=('any')
+url="https://github.com/vinceliuice/stylish-gtk-theme"
+license=('GPL3')
+optdepends=('gtk-engine-murrine: for gtk2 themes'
+ 'gnome-themes-standard: for gtk2 themes')
+makedepends=('gtk3' 'sassc' 'git')
+#conflicts=('stylish-gtk-theme')
+provides=('stylish-gtk-theme')
+source=("git+https://github.com/vinceliuice/stylish-gtk-theme.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/stylish-gtk-theme"
+ echo "$(git log -1 --format=%cs | sed 's/\-/\./g').$(git log -1 --format=%h)"
+}
+
+package() {
+ cd "$srcdir/stylish-gtk-theme"
+ mkdir -p "$pkgdir/usr/share/themes"
+ ./Install --dest "$pkgdir/usr/share/themes"
+}
+