summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlessandro Rizzi2018-04-28 11:27:12 +0200
committerAlessandro Rizzi2018-04-28 11:44:54 +0200
commit648f91ffbb0370d738c956c6334152bd4b7d22f4 (patch)
treedd74760753a30a8213dba1e0e51da19608e070a6
downloadaur-648f91ffbb0370d738c956c6334152bd4b7d22f4.tar.gz
Initial sub-edit-git commit
Signed-off-by: Alessandro Rizzi <alexander89@katamail.com>
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD52
-rw-r--r--sub-edit.desktop10
-rwxr-xr-xsub-edit.sh3
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6fd08aab2e06
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = sub-edit-git
+ pkgdesc = A very simple tool for synchronizing the subtitles of a movie while watching it
+ pkgver = 20180428
+ pkgrel = 1
+ url = https://github.com/alessandrorizzi/sub-edit
+ arch = i686
+ arch = x86_64
+ license = AGPL3
+ makedepends = git
+ makedepends = sbt
+ depends = java-runtime=8
+ depends = sh
+ provides = sub-edit
+ source = git+https://github.com/alessandrorizzi/sub-edit.git
+ source = sub-edit.sh
+ source = sub-edit.desktop
+ sha512sums = SKIP
+ sha512sums = c7db0deab43c89d33a815e973081c7b9890ce42a85c2590d083c1a2167572ca16c02f5485b31da578982de8e38b4262097d8545db1555ae6f5332a7bdc36bed4
+ sha512sums = 50e0cbc6f74d9e99ee2e33f85269bda91f358f9a485618b738ab849670d2891273e5679bb0f1533fce11b37cfc937d3310e732b15c01566a469f9323bf2fd727
+
+pkgname = sub-edit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0eee4eb696d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Alessandro Rizzi <aur@rizzi.re>
+
+pkgname=sub-edit-git
+_pkgname=sub-edit
+pkgver=20180428
+pkgrel=1
+pkgdesc="A very simple tool for synchronizing the subtitles of a movie while watching it"
+arch=('i686' 'x86_64')
+url="https://github.com/alessandrorizzi/sub-edit"
+license=('AGPL3')
+groups=()
+depends=('java-runtime=8' 'sh')
+makedepends=('git' 'sbt')
+optdepends=()
+provides=('sub-edit')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=(
+ git+https://github.com/alessandrorizzi/sub-edit.git
+ sub-edit.sh
+ sub-edit.desktop
+ )
+noextract=()
+sha512sums=(
+ 'SKIP'
+ c7db0deab43c89d33a815e973081c7b9890ce42a85c2590d083c1a2167572ca16c02f5485b31da578982de8e38b4262097d8545db1555ae6f5332a7bdc36bed4
+ 50e0cbc6f74d9e99ee2e33f85269bda91f358f9a485618b738ab849670d2891273e5679bb0f1533fce11b37cfc937d3310e732b15c01566a469f9323bf2fd727
+ )
+
+build() {
+ cd "$srcdir"/"$_pkgname"
+ sbt assembly
+}
+
+package() {
+ cd "$srcdir"/"$_pkgname"
+ mkdir -p "$pkgdir"/usr/{bin,share}
+ mkdir -p "$pkgdir"/usr/share/"$_pkgname"
+ mkdir -p "$pkgdir"/usr/share/applications
+ mkdir -p "$pkgdir"/usr/share/pixmaps
+ install -Dm644 target/scala-2.12/"$_pkgname".jar "$pkgdir"/usr/share/"$_pkgname"
+
+ install -Dm644 "src/main/resources/icon.png" "$pkgdir"/usr/share/pixmaps/"$_pkgname-icon.png"
+
+ cd "$srcdir"
+ install -Dm755 "$_pkgname.sh" "$pkgdir"/usr/bin
+ install -Dm644 "$_pkgname.desktop" "$pkgdir"/usr/share/applications/
+
+}
diff --git a/sub-edit.desktop b/sub-edit.desktop
new file mode 100644
index 000000000000..db71622581e6
--- /dev/null
+++ b/sub-edit.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Sub Edit
+Comment=A simple subtitle editor
+Comment[it]=Un semplice editor di sottotitoli
+Exec=sub-edit.sh
+NoDisplay=false
+Terminal=false
+Icon=/usr/share/pixmaps/sub-edit-icon.png
+Categories=GTK;Application;AudioVideo;
+Type=Application
diff --git a/sub-edit.sh b/sub-edit.sh
new file mode 100755
index 000000000000..17a2d511bcc5
--- /dev/null
+++ b/sub-edit.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /usr/bin/java -jar '/usr/share/sub-edit/sub-edit.jar' "$@"