summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSumner Evans2020-02-01 20:20:28 -0700
committerSumner Evans2020-02-01 20:20:28 -0700
commit2234f90659860162ac0b5fbaf34b98f7def2006f (patch)
treef68e3605d2f2f0d6c11a5d4a100f92912d2eee02
parent675d04e5ebff3eaa2ceaa0ec03f0652df1df6813 (diff)
downloadaur-2234f90659860162ac0b5fbaf34b98f7def2006f.tar.gz
v0.8.10 -> v0.8.11
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD31
-rwxr-xr-xupdate.sh21
4 files changed, 22 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d40792b4f6db..a4ef43323e11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sublime-music
pkgdesc = A native Subsonic/Airsonic/*sonic client for Linux. Build using Python and GTK+.
- pkgver = 0.8.10
- pkgrel = 2
+ pkgver = 0.8.11
+ pkgrel = 1
url = https://gitlab.com/sumner/sublime-music
arch = any
license = GPL3
@@ -9,7 +9,6 @@ pkgbase = sublime-music
makedepends = inkscape
makedepends = make
depends = python
- depends = pygobject-devel
depends = python-bottle
depends = python-dateutil
depends = python-deepdiff
@@ -22,10 +21,12 @@ pkgbase = sublime-music
depends = python-pychromecast
depends = python-requests
depends = python-yaml
- source = https://files.pythonhosted.org/packages/source/s/sublime-music/sublime-music-0.8.10.tar.gz
- source = https://gitlab.com/sumner/sublime-music/-/archive/master/sublime-music-master.tar.gz
- md5sums = 0de18ff308d578d9b2b9baf61c86ce72
- md5sums = 4efb20f1a0c95a6c33d17767a9859623
+ depends = libnm-glib
+ depends = libnotify
+ source = https://files.pythonhosted.org/packages/source/s/sublime-music/sublime-music-0.8.11.tar.gz
+ source = https://gitlab.com/sumner/sublime-music/-/jobs/artifacts/v0.8.11/download?job=build_logo
+ md5sums = 480c6ad8306534e94442fb6d37dcfc9d
+ md5sums = 5202c452ef665c3d17c9c15787aa3276
pkgname = sublime-music
diff --git a/.gitignore b/.gitignore
index 92d3543c2fed..0756d3c9fd7c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
+download?job=build_logo
# Created by https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
index 2f6c4d264b95..9932b0726925 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,12 @@
pkgbase='sublime-music'
pkgname=('sublime-music')
_module='sublime-music'
-pkgver='0.8.10'
-pkgrel=2
+pkgver='0.8.11'
+pkgrel=1
pkgdesc='A native Subsonic/Airsonic/*sonic client for Linux. Build using Python and GTK+.'
url='https://gitlab.com/sumner/sublime-music'
depends=(
'python'
- 'pygobject-devel'
'python-bottle'
'python-dateutil'
'python-deepdiff'
@@ -22,6 +21,8 @@ depends=(
'python-pychromecast'
'python-requests'
'python-yaml'
+ 'libnm-glib'
+ 'libnotify'
)
makedepends=(
'python-setuptools'
@@ -31,25 +32,16 @@ makedepends=(
license=('GPL3')
arch=('any')
source=(
- 'https://files.pythonhosted.org/packages/source/s/sublime-music/sublime-music-0.8.10.tar.gz'
- 'https://gitlab.com/sumner/sublime-music/-/archive/master/sublime-music-master.tar.gz'
+ 'https://files.pythonhosted.org/packages/source/s/sublime-music/sublime-music-0.8.11.tar.gz'
+ 'https://gitlab.com/sumner/sublime-music/-/jobs/artifacts/v0.8.11/download?job=build_logo'
)
-md5sums=('0de18ff308d578d9b2b9baf61c86ce72'
- '4efb20f1a0c95a6c33d17767a9859623')
+md5sums=('480c6ad8306534e94442fb6d37dcfc9d'
+ '5202c452ef665c3d17c9c15787aa3276')
build() {
- pushd ${srcdir}
-
- pushd "${_module}-${pkgver}"
+ cd "${srcdir}/${_module}-${pkgver}"
python setup.py build
- popd
-
- pushd sublime-music-master/docs/logo
- make
- popd
-
- popd
}
package() {
@@ -59,10 +51,6 @@ package() {
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
popd
- pushd sublime-music-master
-
- ls -lah
-
desktop-file-install --dir=${pkgdir}/usr/share/applications sublime-music.desktop
pushd docs/logo/build
@@ -79,7 +67,6 @@ package() {
install -Dm644 512x512.png ${pkgdir}/usr/share/icons/hicolor/512x512/apps/sublime-music.png
install -Dm644 1024x1024.png ${pkgdir}/usr/share/icons/hicolor/1024x1024/apps/sublime-music.png
popd
- popd
popd
}
diff --git a/update.sh b/update.sh
index dd7854d66b88..fe1d75f0b139 100755
--- a/update.sh
+++ b/update.sh
@@ -5,7 +5,6 @@ PROJ_NAME=sublime-music
DESCRIPTION="A native Subsonic/Airsonic/*sonic client for Linux. Build using Python and GTK+."
URL=https://gitlab.com/sumner/sublime-music
DEPENDS=(
- pygobject-devel
python-bottle
python-dateutil
python-deepdiff
@@ -18,6 +17,8 @@ DEPENDS=(
python-pychromecast
python-requests
python-yaml
+ libnm-glib
+ libnotify
)
LICENSE='GPL3'
ADDITIONAL=
@@ -33,7 +34,7 @@ fi
SRCS=(
https://files.pythonhosted.org/packages/source/${PROJ_NAME:0:1}/${PROJ_NAME}/${PROJ_NAME}-$1.tar.gz
- https://gitlab.com/sumner/sublime-music/-/archive/master/sublime-music-master.tar.gz
+ https://gitlab.com/sumner/sublime-music/-/jobs/artifacts/v$1/download?job=build_logo
)
printf '' > PKGBUILD
@@ -74,17 +75,8 @@ md5sums=()
${ADDITIONAL}
build() {
- pushd \${srcdir}
-
- pushd \"\${_module}-\${pkgver}\"
+ cd \"\${srcdir}/\${_module}-\${pkgver}\"
python setup.py build
- popd
-
- pushd sublime-music-master/docs/logo
- make
- popd
-
- popd
}
package() {
@@ -94,10 +86,6 @@ package() {
python setup.py install --root=\"\${pkgdir}\" --optimize=1 --skip-build
popd
- pushd sublime-music-master
-
- ls -lah
-
desktop-file-install --dir=\${pkgdir}/usr/share/applications sublime-music.desktop
pushd docs/logo/build
@@ -114,7 +102,6 @@ package() {
install -Dm644 512x512.png \${pkgdir}/usr/share/icons/hicolor/512x512/apps/sublime-music.png
install -Dm644 1024x1024.png \${pkgdir}/usr/share/icons/hicolor/1024x1024/apps/sublime-music.png
popd
- popd
popd
}" >> PKGBUILD