summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSumner Evans2020-07-11 10:51:30 -0600
committerSumner Evans2020-07-11 10:51:30 -0600
commit5985199c5d1f144a1617f5dca6151c26dcab6dfb (patch)
tree244eef1fab83d089dab508c1d238ae441d430ead
parent0376beccad3dca8dc648c998fa411c7c146ba043 (diff)
downloadaur-5985199c5d1f144a1617f5dca6151c26dcab6dfb.tar.gz
0.10.3 -> 0.11.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD20
-rwxr-xr-xupdate.sh8
3 files changed, 24 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2bd45bf60cb..e59fed91530a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = sublime-music
pkgdesc = A native Subsonic/Airsonic/*sonic client for Linux. Build using Python and GTK+.
- pkgver = 0.10.3
- pkgrel = 2
+ pkgver = 0.11.0
+ pkgrel = 1
url = https://sublimemusic.app
arch = any
license = GPL3
makedepends = python-setuptools
depends = python
- depends = python-bottle
depends = python-dataclasses-json
depends = python-dateutil
depends = python-deepdiff
@@ -16,15 +15,16 @@ pkgbase = sublime-music
depends = python-levenshtein
depends = python-mpv
depends = python-peewee
- depends = python-pychromecast
depends = python-requests
- optdepends = python-keyring: support for storing passwords in the system keyring
- optdepends = libnotify: for system song notification support
optdepends = libnm-glib: for changing the Subsonic server address depending on what SSID you are connected to
- source = https://files.pythonhosted.org/packages/source/s/sublime-music/sublime-music-0.10.3.tar.gz
- source = https://gitlab.com/sumner/sublime-music/-/archive/v0.10.3/sublime-music-v0.10.3.tar.gz
- md5sums = b948089719b77b66e0e00409565afc32
- md5sums = 67e01bc71d4c6947274bab3800837a60
+ optdepends = libnotify: for system song notification support
+ optdepends = python-keyring: support for storing passwords in the system keyring
+ optdepends = python-pychromecast: support for casting to Chromecast devices
+ optdepends = python-bottle: support for casting downloaded files to Chromecasts on the same LAN
+ source = https://files.pythonhosted.org/packages/source/s/sublime-music/sublime-music-0.11.0.tar.gz
+ source = https://gitlab.com/sumner/sublime-music/-/archive/v0.11.0/sublime-music-v0.11.0.tar.gz
+ md5sums = bba062cb7fbd44eda97bfde7d65ee8cc
+ md5sums = 43a7f10ff933e8f321f745638c5e9634
pkgname = sublime-music
diff --git a/PKGBUILD b/PKGBUILD
index edaf14164b20..c05281cbc1e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,12 @@
pkgbase='sublime-music'
pkgname=('sublime-music')
_module='sublime-music'
-pkgver='0.10.3'
-pkgrel=2
+pkgver='0.11.0'
+pkgrel=1
pkgdesc='A native Subsonic/Airsonic/*sonic client for Linux. Build using Python and GTK+.'
url='https://sublimemusic.app'
depends=(
'python'
- 'python-bottle'
'python-dataclasses-json'
'python-dateutil'
'python-deepdiff'
@@ -18,13 +17,14 @@ depends=(
'python-levenshtein'
'python-mpv'
'python-peewee'
- 'python-pychromecast'
'python-requests'
)
optdepends=(
- 'python-keyring: support for storing passwords in the system keyring'
- 'libnotify: for system song notification support'
'libnm-glib: for changing the Subsonic server address depending on what SSID you are connected to'
+ 'libnotify: for system song notification support'
+ 'python-keyring: support for storing passwords in the system keyring'
+ 'python-pychromecast: support for casting to Chromecast devices'
+ 'python-bottle: support for casting downloaded files to Chromecasts on the same LAN'
)
makedepends=(
'python-setuptools'
@@ -32,11 +32,11 @@ makedepends=(
license=('GPL3')
arch=('any')
source=(
- 'https://files.pythonhosted.org/packages/source/s/sublime-music/sublime-music-0.10.3.tar.gz'
- 'https://gitlab.com/sumner/sublime-music/-/archive/v0.10.3/sublime-music-v0.10.3.tar.gz'
+ 'https://files.pythonhosted.org/packages/source/s/sublime-music/sublime-music-0.11.0.tar.gz'
+ 'https://gitlab.com/sumner/sublime-music/-/archive/v0.11.0/sublime-music-v0.11.0.tar.gz'
)
-md5sums=('b948089719b77b66e0e00409565afc32'
- '67e01bc71d4c6947274bab3800837a60')
+md5sums=('bba062cb7fbd44eda97bfde7d65ee8cc'
+ '43a7f10ff933e8f321f745638c5e9634')
build() {
diff --git a/update.sh b/update.sh
index 8f1380adae7f..70779331a6df 100755
--- a/update.sh
+++ b/update.sh
@@ -5,7 +5,6 @@ PROJ_NAME=sublime-music
DESCRIPTION="A native Subsonic/Airsonic/*sonic client for Linux. Build using Python and GTK+."
URL=https://sublimemusic.app
DEPENDS=(
- python-bottle
python-dataclasses-json
python-dateutil
python-deepdiff
@@ -14,7 +13,6 @@ DEPENDS=(
python-levenshtein
python-mpv
python-peewee
- python-pychromecast
python-requests
)
LICENSE='GPL3'
@@ -59,9 +57,11 @@ done
echo ")
optdepends=(
- 'python-keyring: support for storing passwords in the system keyring'
- 'libnotify: for system song notification support'
'libnm-glib: for changing the Subsonic server address depending on what SSID you are connected to'
+ 'libnotify: for system song notification support'
+ 'python-keyring: support for storing passwords in the system keyring'
+ 'python-pychromecast: support for casting to Chromecast devices'
+ 'python-bottle: support for casting downloaded files to Chromecasts on the same LAN'
)
makedepends=(
'python-setuptools'