summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSumner Evans2020-06-07 20:59:57 -0600
committerSumner Evans2020-06-07 20:59:57 -0600
commit96715e2ffceafa6d796bdaf2605154def94438f6 (patch)
tree688bfd2be86efd624c20a15382fbc3d3eba33687
parentb2b5f1103494ab82fd8aee7651ef57fd50b77af0 (diff)
downloadaur-96715e2ffceafa6d796bdaf2605154def94438f6.tar.gz
Fixing dependencies
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
-rwxr-xr-xupdate.sh7
3 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1852deff9e9e..08bc6ed27ebf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,26 @@
pkgbase = sublime-music
pkgdesc = A native Subsonic/Airsonic/*sonic client for Linux. Build using Python and GTK+.
pkgver = 0.10.3
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/sumner/sublime-music
arch = any
license = GPL3
makedepends = python-setuptools
depends = python
- depends = libnm-glib
- depends = libnotify
depends = python-bottle
depends = python-dataclasses-json
depends = python-dateutil
depends = python-deepdiff
- depends = python-deprecated
depends = python-fuzzywuzzy
depends = python-gobject
depends = python-levenshtein
depends = python-mpv
+ depends = python-peewee
depends = python-pychromecast
depends = python-requests
- depends = python-yaml
optdepends = python-keyring: support for storing passwords in the system keyring
+ optdepends = libnotify: for system song notification support
+ optdepends = libnm-glib: for changing the Subsonic server address depending on what SSID you are connected to
source = https://files.pythonhosted.org/packages/source/s/sublime-music/sublime-music-0.10.3.tar.gz
source = https://gitlab.com/sumner/sublime-music/-/archive/v0.10.3/sublime-music-v0.10.3.tar.gz
md5sums = b948089719b77b66e0e00409565afc32
diff --git a/PKGBUILD b/PKGBUILD
index ec69d4d062b4..72e403e52160 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,27 @@ pkgbase='sublime-music'
pkgname=('sublime-music')
_module='sublime-music'
pkgver='0.10.3'
-pkgrel=1
+pkgrel=2
pkgdesc='A native Subsonic/Airsonic/*sonic client for Linux. Build using Python and GTK+.'
url='https://gitlab.com/sumner/sublime-music'
depends=(
'python'
- 'libnm-glib'
- 'libnotify'
'python-bottle'
'python-dataclasses-json'
'python-dateutil'
'python-deepdiff'
- 'python-deprecated'
'python-fuzzywuzzy'
'python-gobject'
'python-levenshtein'
'python-mpv'
+ 'python-peewee'
'python-pychromecast'
'python-requests'
- 'python-yaml'
)
optdepends=(
'python-keyring: support for storing passwords in the system keyring'
+ 'libnotify: for system song notification support'
+ 'libnm-glib: for changing the Subsonic server address depending on what SSID you are connected to'
)
makedepends=(
'python-setuptools'
diff --git a/update.sh b/update.sh
index a38609142537..38c45f7cf716 100755
--- a/update.sh
+++ b/update.sh
@@ -5,20 +5,17 @@ PROJ_NAME=sublime-music
DESCRIPTION="A native Subsonic/Airsonic/*sonic client for Linux. Build using Python and GTK+."
URL=https://gitlab.com/sumner/sublime-music
DEPENDS=(
- libnm-glib
- libnotify
python-bottle
python-dataclasses-json
python-dateutil
python-deepdiff
- python-deprecated
python-fuzzywuzzy
python-gobject
python-levenshtein
python-mpv
+ python-peewee
python-pychromecast
python-requests
- python-yaml
)
LICENSE='GPL3'
ADDITIONAL=
@@ -63,6 +60,8 @@ done
echo ")
optdepends=(
'python-keyring: support for storing passwords in the system keyring'
+ 'libnotify: for system song notification support'
+ 'libnm-glib: for changing the Subsonic server address depending on what SSID you are connected to'
)
makedepends=(
'python-setuptools'