summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSumner Evans2020-05-05 11:18:39 -0600
committerSumner Evans2020-05-05 11:18:39 -0600
commitc7c05e93ad29222178519e82a3592e2353766e99 (patch)
tree84c4ed02308236ba47999069c220067f4a9f2cc8
parent0afdd5b78f84f3e1bfc293e3d2f53b717951666b (diff)
downloadaur-c7c05e93ad29222178519e82a3592e2353766e99.tar.gz
Include the logo in the repo
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD6
-rw-r--r--logo.zipbin0 -> 153141 bytes
-rwxr-xr-xupdate.sh9
5 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb3087b04f03..112dd4c51cd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sublime-music
pkgdesc = A native Subsonic/Airsonic/*sonic client for Linux. Build using Python and GTK+.
pkgver = 0.9.1
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.com/sumner/sublime-music
arch = any
license = GPL3
@@ -24,9 +24,9 @@ pkgbase = sublime-music
depends = libnm-glib
depends = libnotify
source = https://files.pythonhosted.org/packages/source/s/sublime-music/sublime-music-0.9.1.tar.gz
- source = https://gitlab.com/sumner/sublime-music/-/jobs/artifacts/v0.9.1/download?job=build_logo
+ source = logo.zip
md5sums = 547c4c6d13101a6478588640de5d2dcd
- md5sums = 175ca5becfa508b3d8e13ca3a621dac2
+ md5sums = bb699422aa5809f785c23dda52035321
pkgname = sublime-music
diff --git a/.gitignore b/.gitignore
index 0756d3c9fd7c..30bec9965391 100644
--- a/.gitignore
+++ b/.gitignore
@@ -18,3 +18,5 @@ pkg/
src/
# End of https://www.gitignore.io/api/archlinuxpackages
+
+!logo.zip
diff --git a/PKGBUILD b/PKGBUILD
index 798a24e6408d..69d1b8a9c946 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase='sublime-music'
pkgname=('sublime-music')
_module='sublime-music'
pkgver='0.9.1'
-pkgrel=2
+pkgrel=3
pkgdesc='A native Subsonic/Airsonic/*sonic client for Linux. Build using Python and GTK+.'
url='https://gitlab.com/sumner/sublime-music'
depends=(
@@ -33,10 +33,10 @@ license=('GPL3')
arch=('any')
source=(
'https://files.pythonhosted.org/packages/source/s/sublime-music/sublime-music-0.9.1.tar.gz'
- 'https://gitlab.com/sumner/sublime-music/-/jobs/artifacts/v0.9.1/download?job=build_logo'
+ 'logo.zip'
)
md5sums=('547c4c6d13101a6478588640de5d2dcd'
- '175ca5becfa508b3d8e13ca3a621dac2')
+ 'bb699422aa5809f785c23dda52035321')
build() {
diff --git a/logo.zip b/logo.zip
new file mode 100644
index 000000000000..16acaae8b6b1
--- /dev/null
+++ b/logo.zip
Binary files differ
diff --git a/update.sh b/update.sh
index 458e1fd1e168..a41c5438459e 100755
--- a/update.sh
+++ b/update.sh
@@ -32,13 +32,16 @@ if [[ $# == 2 ]]; then
pkgrel=$2
fi
+# Manually download the logo build artifact to avoid the fact that the GitLab
+# artifacts download using the tag may give you an incorrect version of the
+# logo build artifacts.
+wget -O logo.zip "https://gitlab.com/sumner/sublime-music/-/jobs/artifacts/v$1/download?job=build_logo"
+
SRCS=(
https://files.pythonhosted.org/packages/source/${PROJ_NAME:0:1}/${PROJ_NAME}/${PROJ_NAME}-$1.tar.gz
- https://gitlab.com/sumner/sublime-music/-/jobs/artifacts/v$1/download?job=build_logo
+ logo.zip
)
-rm -rf 'download?job=build_logo'
-
printf '' > PKGBUILD
echo "# Maintainer: Sumner Evans <sumner.evans98 at gmail dot com>