summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSumner Evans2020-06-01 19:57:47 -0600
committerSumner Evans2020-06-01 19:57:47 -0600
commite52d5033e6c893a94b2238909af7c78a91d5aa92 (patch)
tree29b2684d58ed1f848485f665fcf72c7ea77d3bf7
parent5db21b8769da478d0bdaab9ec95c5ab612ccca11 (diff)
downloadaur-e52d5033e6c893a94b2238909af7c78a91d5aa92.tar.gz
Fix dependencies
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rwxr-xr-xupdate.sh8
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5a89e426d20..8ab75bb47fb0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = sublime-music
pkgdesc = A native Subsonic/Airsonic/*sonic client for Linux. Build using Python and GTK+.
pkgver = 0.9.2
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/sumner/sublime-music
arch = any
license = GPL3
makedepends = python-setuptools
- makedepends = inkscape
- makedepends = make
depends = python
+ depends = libnm-glib
+ depends = libnotify
depends = python-bottle
+ depends = python-dateutil
depends = python-deepdiff
+ depends = python-deprecated
depends = python-fuzzywuzzy
depends = python-gobject
depends = python-levenshtein
@@ -18,8 +20,6 @@ pkgbase = sublime-music
depends = python-pychromecast
depends = python-requests
depends = python-yaml
- depends = libnm-glib
- depends = libnotify
optdepends = python-keyring: support for storing passwords in the system keyring
source = https://files.pythonhosted.org/packages/source/s/sublime-music/sublime-music-0.9.2.tar.gz
source = https://gitlab.com/sumner/sublime-music/-/archive/v0.9.2/sublime-music-v0.9.2.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 5047dcd71bbc..894e9e7dc7d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,17 @@ pkgbase='sublime-music'
pkgname=('sublime-music')
_module='sublime-music'
pkgver='0.9.2'
-pkgrel=1
+pkgrel=2
pkgdesc='A native Subsonic/Airsonic/*sonic client for Linux. Build using Python and GTK+.'
url='https://gitlab.com/sumner/sublime-music'
depends=(
'python'
+ 'libnm-glib'
+ 'libnotify'
'python-bottle'
+ 'python-dateutil'
'python-deepdiff'
+ 'python-deprecated'
'python-fuzzywuzzy'
'python-gobject'
'python-levenshtein'
@@ -18,16 +22,12 @@ depends=(
'python-pychromecast'
'python-requests'
'python-yaml'
- 'libnm-glib'
- 'libnotify'
)
optdepends=(
'python-keyring: support for storing passwords in the system keyring'
)
makedepends=(
'python-setuptools'
- 'inkscape'
- 'make'
)
license=('GPL3')
arch=('any')
diff --git a/update.sh b/update.sh
index 51c229293288..e9ad49917b8d 100755
--- a/update.sh
+++ b/update.sh
@@ -5,8 +5,12 @@ PROJ_NAME=sublime-music
DESCRIPTION="A native Subsonic/Airsonic/*sonic client for Linux. Build using Python and GTK+."
URL=https://gitlab.com/sumner/sublime-music
DEPENDS=(
+ libnm-glib
+ libnotify
python-bottle
+ python-dateutil
python-deepdiff
+ python-deprecated
python-fuzzywuzzy
python-gobject
python-levenshtein
@@ -14,8 +18,6 @@ DEPENDS=(
python-pychromecast
python-requests
python-yaml
- libnm-glib
- libnotify
)
LICENSE='GPL3'
ADDITIONAL=
@@ -63,8 +65,6 @@ optdepends=(
)
makedepends=(
'python-setuptools'
- 'inkscape'
- 'make'
)
license=('${LICENSE}')
arch=('any')