summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSumner Evans2020-11-21 17:11:57 -0700
committerSumner Evans2020-11-21 17:11:57 -0700
commit9c98b5a7b31abc212fd3d0ee5eee9c637c7eeb77 (patch)
treebeffa0d041f3b54af0d8ef8142f5264d50a6c5b1
parent595ececc990580e5335a8ee966ce7eca1c432d6f (diff)
downloadaur-9c98b5a7b31abc212fd3d0ee5eee9c637c7eeb77.tar.gz
Update to use poetry for build and pip to install
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c822ea23b056..809131a77144 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = sublime-music-git
pkgdesc = A native Subsonic/Airsonic/*sonic client for Linux. Built using Python and GTK+.
- pkgver = v0.11.9.r0.gd454b90
- pkgrel = 4
+ pkgver = v0.11.10.r13.g8fef15b
+ pkgrel = 1
url = https://sublimemusic.app
arch = any
license = GPL3
- makedepends = python-setuptools
+ makedepends = python-pip
+ makedepends = python-poetry
makedepends = python-sphinx
+ makedepends = tar
depends = python
depends = python-bleach
depends = python-dataclasses-json
diff --git a/PKGBUILD b/PKGBUILD
index 5efa112bd0c8..32c0612ac573 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgbase='sublime-music-git'
pkgname=('sublime-music-git')
_module='sublime-music'
-pkgver=v0.11.9.r0.gd454b90
-pkgrel=4
+pkgver=v0.11.10.r13.g8fef15b
+pkgrel=1
pkgdesc='A native Subsonic/Airsonic/*sonic client for Linux. Built using Python and GTK+.'
url='https://sublimemusic.app'
provides=('sublime-music')
@@ -31,8 +31,10 @@ optdepends=(
'python-bottle: support for casting downloaded files to Chromecasts on the same LAN'
)
makedepends=(
- 'python-setuptools'
+ 'python-pip'
+ 'python-poetry'
'python-sphinx'
+ 'tar'
)
license=('GPL3')
arch=('any')
@@ -49,12 +51,12 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname}"
- python setup.py build
+ poetry build
}
package() {
cd "${srcdir}/${pkgname}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ pip install dist/sublime_music-*.tar.gz --root="${pkgdir}"
# Move all of the package data resources to ${pkgdir}/usr/share/sublime-music
data_dir=${pkgdir}/usr/share/sublime-music