summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWu Zhenyu2023-07-21 00:51:50 +0800
committerWu Zhenyu2023-07-21 00:51:50 +0800
commitc7720befc270cc64df17e34906597f65a19db165 (patch)
tree598fd72802e540384d7dc7d195a446482bfe7047
parentbb0e94243e07e9b5b5767ecb22494bd96265376b (diff)
downloadaur-c7720befc270cc64df17e34906597f65a19db165.tar.gz
:truck: Strip "python-" to respect Arch wiki's Python package guidelines
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f0f2c77711e..7905afbef185 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = python-sublime-syntax-language-server
+pkgbase = sublime-syntax-language-server
pkgdesc = sublime-syntax language server
pkgver = 0.0.3
pkgrel = 1
@@ -12,4 +12,4 @@ pkgbase = python-sublime-syntax-language-server
source = https://files.pythonhosted.org/packages/py3/s/sublime_syntax_language_server/sublime_syntax_language_server-0.0.3-py3-none-any.whl
sha256sums = fa28463d52904f15d392175e8e935c3520e18130dfc3fa249df2f2a027d4c714
-pkgname = python-sublime-syntax-language-server
+pkgname = sublime-syntax-language-server
diff --git a/PKGBUILD b/PKGBUILD
index 6f99591b3e54..4e8e51e78c99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# shellcheck shell=bash disable=SC2034,SC2154
-_pkgname=sublime-syntax-language-server
-pkgname="python-$_pkgname"
+# Maintainer: Wu Zhenyu <wuzhenyu@ustc.edu>
+# Updated by https://github.com/Freed-Wu/autoconf-language-server/blob/main/.github/workflows/main.yml
+pkgname=sublime-syntax-language-server
pkgver=0.0.3
pkgrel=1
pkgdesc="sublime-syntax language server"
@@ -11,7 +12,7 @@ optdepends=(python-beautifulsoup4)
makedepends=(python-installer)
license=(GPL3)
_py=py3
-source=("https://files.pythonhosted.org/packages/$_py/${_pkgname::1}/${_pkgname//-/_}/${_pkgname//-/_}-$pkgver-$_py-none-any.whl")
+source=("https://files.pythonhosted.org/packages/$_py/${pkgname::1}/${pkgname//-/_}/${pkgname//-/_}-$pkgver-$_py-none-any.whl")
sha256sums=('fa28463d52904f15d392175e8e935c3520e18130dfc3fa249df2f2a027d4c714')
package() {