summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2015-04-15 23:42:54 +0200
committerCarsten Teibes2015-04-15 23:42:54 +0200
commit3d5d2e1bf94c5075a40b4f1f5f5d4bca46aa5e3f (patch)
tree4bf5b6e121995a92a2dbd706079f1a762f80d3e8
parent200b0ec02cb6fa21cb55b21e3d6604eaaa5d9cba (diff)
downloadaur-3d5d2e1bf94c5075a40b4f1f5f5d4bca46aa5e3f.tar.gz
[fix] Include EULA snapshot
The website metadata changed, this prevents outdated checksums.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
-rw-r--r--sublime-text-EULA51
3 files changed, 60 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16955b945e9d..289b6446b002 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,6 @@ pkgbase = sublime-text
arch = i686
arch = x86_64
license = custom
- makedepends = python-html2text
depends = libpng
depends = gtk2
depends = bash
@@ -15,7 +14,7 @@ pkgbase = sublime-text
depends = xdg-utils
depends = desktop-file-utils
depends = shared-mime-info
- source = sublime-text-eula.html::http://www.sublimetext.com/eula
+ source = sublime-text-EULA
source = sublime-text.desktop
source = sublime-text.sh
source = http://downloads.sourceforge.net/libpng/libpng-1.6.2.tar.xz
@@ -23,7 +22,7 @@ pkgbase = sublime-text
source = 0001-libpng16-Avoid-dereferencing-NULL-pointer-possibly-r.patch
source = 0002-libpng16-Calculate-our-own-zlib-windowBits-when-deco.patch
source = adjust-apng-patch-for-libpng16-git-changes.patch
- sha256sums = 89c40c61b51aaa57693234e8fc9b007c787c00e75f7eef8d817146ba729ef82f
+ sha256sums = 43aa2cf3becee23697177c6e6ecd4fc2c4b459499631bfdb2533cdb60c27530e
sha256sums = 3f11bf8cb814b68ed81b535dd13cc86bb28c71010d74141bfa06137782fd2f7d
sha256sums = 765c8a65ef429dc81a983d14d94c97a2d185575d74e702861ad3e374e2759338
sha256sums = 1c97a90bc22107e50f04f77a0115f4ec890d5c6a373ac4c560e8fb87259e92de
diff --git a/PKGBUILD b/PKGBUILD
index 7e9b79ba2c11..e3f92a97ed00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,9 +12,10 @@ url="http://www.sublimetext.com/2"
license=('custom')
depends=("libpng" "gtk2" "bash" "procps-ng" "xdg-utils" "desktop-file-utils"
"shared-mime-info")
-makedepends=("python-html2text")
install="$pkgname.install"
-source=("$pkgname-eula.html"::"http://www.sublimetext.com/eula"
+ # EULA file is from http://www.sublimetext.com/eula
+ # converted with 'html2text --ignore-links --body-width=80'
+source=("$pkgname-EULA"
"$pkgname.desktop"
"$pkgname.sh"
"http://downloads.sourceforge.net/libpng/libpng-1.6.2.tar.xz"
@@ -22,9 +23,9 @@ source=("$pkgname-eula.html"::"http://www.sublimetext.com/eula"
"0001-libpng16-Avoid-dereferencing-NULL-pointer-possibly-r.patch"
"0002-libpng16-Calculate-our-own-zlib-windowBits-when-deco.patch"
"adjust-apng-patch-for-libpng16-git-changes.patch")
-source_x86_64=("http://c758482.r82.cf2.rackcdn.com/Sublime%20Text%20${pkgver}%20x64.tar.bz2")
source_i686=("http://c758482.r82.cf2.rackcdn.com/Sublime%20Text%20${pkgver}.tar.bz2")
-sha256sums=('89c40c61b51aaa57693234e8fc9b007c787c00e75f7eef8d817146ba729ef82f'
+source_x86_64=("http://c758482.r82.cf2.rackcdn.com/Sublime%20Text%20${pkgver}%20x64.tar.bz2")
+sha256sums=('43aa2cf3becee23697177c6e6ecd4fc2c4b459499631bfdb2533cdb60c27530e'
'3f11bf8cb814b68ed81b535dd13cc86bb28c71010d74141bfa06137782fd2f7d'
'765c8a65ef429dc81a983d14d94c97a2d185575d74e702861ad3e374e2759338'
'1c97a90bc22107e50f04f77a0115f4ec890d5c6a373ac4c560e8fb87259e92de'
@@ -32,14 +33,10 @@ sha256sums=('89c40c61b51aaa57693234e8fc9b007c787c00e75f7eef8d817146ba729ef82f'
'0632ea1d588cb7b85dfc2c13444de1682e9d7e61caaf8cce118fc535bc9f4d90'
'2a65904c85ff492d4f91edd55e17f81ba36ee6af1cac7402f786580f3fc56216'
'1f51e33233ce560c5d8002bc096aa4cc5be70c082e08b14db4376a9a02f2714a')
-sha256sums_x86_64=('01baed30d66432e30002a309ff0393967be1daba5cce653e43bba6bd6c38ab84')
sha256sums_i686=('07338e041cfb348938fa8069f0aad3b5b43c319b7ec564ffff1489796f2dcf08')
+sha256sums_x86_64=('01baed30d66432e30002a309ff0393967be1daba5cce653e43bba6bd6c38ab84')
prepare() {
- # convert license
- html2text --ignore-links --body-width=80 $pkgname-eula.html > EULA
- sed '/EULA/,$!d' -i EULA
-
# libpng
rm -rf png_fake_install
mkdir png_fake_install
@@ -73,7 +70,7 @@ package () {
done
# license
- install -Dm644 EULA "$pkgdir"/usr/share/licenses/$pkgname/EULA
+ install -Dm644 $pkgname-EULA "$pkgdir"/usr/share/licenses/$pkgname/EULA
# libpng
install -m644 png_fake_install/lib/libpng16.so.16.2.0 \
diff --git a/sublime-text-EULA b/sublime-text-EULA
new file mode 100644
index 000000000000..7682a5a80a36
--- /dev/null
+++ b/sublime-text-EULA
@@ -0,0 +1,51 @@
+# EULA
+
+The SOFTWARE PRODUCT (SUBLIME TEXT) is protected by copyright laws and
+international copyright treaties, as well as other intellectual property laws
+and treaties. The SOFTWARE PRODUCT is licensed, not sold.
+
+ 1. LICENSES
+SUBLIME TEXT is licensed as follows:
+
+ 1. Installation and Usage.
+Licenses are per user and valid for use on all supported operating systems.
+License keys may be used on multiple computers and operating systems, provided
+the license key holder is the primary user. Businesses must purchase at least as
+many licenses as the number of people using SUBLIME TEXT.
+
+ 2. Backup Copies.
+You may make copies of the license key and or SUBLIME TEXT for backup and
+archival purposes.
+
+ 2. DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS
+ 1. Maintenance of Copyright Notices.
+You must not remove or alter any copyright notices on any copy of SUBLIME TEXT.
+
+ 2. Distribution.
+You may not distribute or sell license keys or SUBLIME TEXT to third parties.
+Licenses will be revoked if distributed or sold to third parties.
+
+ 3. Rental.
+You may not rent, lease, or lend the license key or SUBLIME TEXT.
+
+ 3. COPYRIGHT
+All title, including but not limited to copyrights, in and to SUBLIME TEXT and
+any copies thereof are owned by SUBLIME HQ PTY LTD.
+
+ 4. NO WARRANTIES
+SUBLIME HQ PTY LTD expressly disclaims any warranty for SUBLIME TEXT, which is
+provided 'as is' without any express or implied warranty of any kind, including
+but not limited to any warranties of merchantability, non-infringement, or
+fitness of a particular purpose.
+
+ 5. LIMITATION OF LIABILITY
+In no event shall SUBLIME HQ PTY LTD be liable for any damages due to use of
+SUBLIME TEXT, to the maximum extent permitted by law. This includes without
+limitation, lost profits, business interruption, or lost information. In no
+event will SUBLIME HQ PTY LTD be liable for loss of data or for indirect,
+special, incidental, consequential (including lost profit), or other damages.
+SUBLIME HQ PTY LTD shall have no liability with respect to the content of
+SUBLIME TEXT or any part thereof, including but not limited to errors or
+omissions contained therein, libel, trademark rights, business interruption,
+loss of privacy or the disclosure of confidential information.
+