summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Hüsers2022-11-15 17:00:45 +0100
committerManuel Hüsers2022-11-15 17:00:45 +0100
commit101ce205999f4724353f5053668a8e52cdfa5e6e (patch)
tree674c74d8a66c9fdafd048c20b56cf43a9bd40890
parent0a947ac2442e5b8e09457f429e119e55a8e1aeda (diff)
downloadaur-101ce205999f4724353f5053668a8e52cdfa5e6e.tar.gz
Allow installation next to sublime-text
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD12
-rw-r--r--sublime-text-2-EULA (renamed from sublime-text2-EULA)0
-rw-r--r--sublime-text-2.desktop (renamed from sublime-text2.desktop)4
-rw-r--r--sublime-text-2.sh (renamed from sublime-text2.sh)2
5 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2e03f73061b..82720a5a8340 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
-pkgbase = sublime-text2
+pkgbase = sublime-text-2
pkgdesc = Sophisticated text editor for code, html and prose (legacy version)
pkgver = 2.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.sublimetext.com/2
arch = i686
arch = x86_64
@@ -12,18 +12,17 @@ pkgbase = sublime-text2
depends = xdg-utils
depends = desktop-file-utils
depends = shared-mime-info
- conflicts = sublime-text
- source = sublime-text2-EULA
- source = sublime-text2.desktop
- source = sublime-text2.sh
+ source = sublime-text-2-EULA
+ source = sublime-text-2.desktop
+ source = sublime-text-2.sh
source = http://downloads.sourceforge.net/libpng/libpng-1.6.2.tar.xz
source = http://downloads.sourceforge.net/libpng-apng/libpng-1.6.2-apng.patch.gz
source = 0001-libpng16-Avoid-dereferencing-NULL-pointer-possibly-r.patch
source = 0002-libpng16-Calculate-our-own-zlib-windowBits-when-deco.patch
source = adjust-apng-patch-for-libpng16-git-changes.patch
sha256sums = dec26169ec941f1089810b7be599193577d0250f20e465d1399b062f71f2a244
- sha256sums = 7a3d0ea23fc0eb8d1e4d322df96a18aab214f8f7ef5808a60f9ad4866c0fc14b
- sha256sums = 153cfa48f8f058cba03e30aa39dc90d9b9ab1d07ce9bfb3bceb78b2c699c47e8
+ sha256sums = f2815b2b73d81ca83d71956f7f97d3b8d386f9175a612531838e6b9d311c1890
+ sha256sums = 026acee29d3c7ba4763d6b99df5be8da69991355adfd6027c2ced266f2721c88
sha256sums = 1c97a90bc22107e50f04f77a0115f4ec890d5c6a373ac4c560e8fb87259e92de
sha256sums = 4196f3c3894f455a78a65170209fc948b01a7448304d8c39bc29d37852b8c73b
sha256sums = 0632ea1d588cb7b85dfc2c13444de1682e9d7e61caaf8cce118fc535bc9f4d90
@@ -34,5 +33,4 @@ pkgbase = sublime-text2
source_x86_64 = https://download.sublimetext.com/Sublime%20Text%202.0.2%20x64.tar.bz2
sha256sums_x86_64 = 01baed30d66432e30002a309ff0393967be1daba5cce653e43bba6bd6c38ab84
-pkgname = sublime-text2
-
+pkgname = sublime-text-2
diff --git a/PKGBUILD b/PKGBUILD
index b3a9ffa5c48c..ea173cf040d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: Manuel Hüsers <aur@huesers.de>
-pkgname=sublime-text2
+pkgname=sublime-text-2
pkgver=2.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="Sophisticated text editor for code, html and prose (legacy version)"
arch=('i686' 'x86_64')
url="https://www.sublimetext.com/2"
license=('custom: commercial')
depends=("libpng" "gtk2" "bash" "xdg-utils" "desktop-file-utils" "shared-mime-info")
-conflicts=("sublime-text")
# EULA file: 'html2text --body-width=80 https://www.sublimetext.com/eula'
source=("$pkgname-EULA"
"$pkgname.desktop"
@@ -21,8 +21,8 @@ source=("$pkgname-EULA"
source_i686=("https://download.sublimetext.com/Sublime%20Text%20${pkgver}.tar.bz2")
source_x86_64=("https://download.sublimetext.com/Sublime%20Text%20${pkgver}%20x64.tar.bz2")
sha256sums=('dec26169ec941f1089810b7be599193577d0250f20e465d1399b062f71f2a244'
- '7a3d0ea23fc0eb8d1e4d322df96a18aab214f8f7ef5808a60f9ad4866c0fc14b'
- '153cfa48f8f058cba03e30aa39dc90d9b9ab1d07ce9bfb3bceb78b2c699c47e8'
+ 'f2815b2b73d81ca83d71956f7f97d3b8d386f9175a612531838e6b9d311c1890'
+ '026acee29d3c7ba4763d6b99df5be8da69991355adfd6027c2ced266f2721c88'
'1c97a90bc22107e50f04f77a0115f4ec890d5c6a373ac4c560e8fb87259e92de'
'4196f3c3894f455a78a65170209fc948b01a7448304d8c39bc29d37852b8c73b'
'0632ea1d588cb7b85dfc2c13444de1682e9d7e61caaf8cce118fc535bc9f4d90'
@@ -54,7 +54,7 @@ package () {
cp -r "Sublime Text 2" "$pkgdir"/opt/$pkgname
# launcher
- install -Dm0755 $pkgname.sh "$pkgdir"/usr/bin/subl
+ install -Dm0755 $pkgname.sh "$pkgdir"/usr/bin/subl2
# .desktop file and icons
install -Dm0644 $pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
diff --git a/sublime-text2-EULA b/sublime-text-2-EULA
index f089c94b4c6a..f089c94b4c6a 100644
--- a/sublime-text2-EULA
+++ b/sublime-text-2-EULA
diff --git a/sublime-text2.desktop b/sublime-text-2.desktop
index f8bc3e29a50c..420fd5851c93 100644
--- a/sublime-text2.desktop
+++ b/sublime-text-2.desktop
@@ -3,8 +3,8 @@ Type=Application
Name=Sublime Text 2
GenericName=Editor
Comment=Sophisticated text editor for code, html and prose (legacy version)
-Exec=subl %F
-Icon=sublime-text2
+Exec=/usr/bin/subl2 %F
+Icon=sublime-text-2
Categories=Utility;TextEditor;
Terminal=false
StartupWMClass=sublime_text
diff --git a/sublime-text2.sh b/sublime-text-2.sh
index 2df213db10c0..a703085a8ae1 100644
--- a/sublime-text2.sh
+++ b/sublime-text-2.sh
@@ -1,6 +1,6 @@
#!/bin/bash
-ST=/opt/sublime-text2
+ST=/opt/sublime-text-2
# needed for .desktop launcher
ARGS="--class=sublime_text"