aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Marcos2019-11-13 12:13:38 -0300
committerJoão Marcos2019-11-13 12:13:38 -0300
commit65321dcaa8885506f14a8fc96e4c78e4430b9e8f (patch)
treefd3a6401cc9e8d8100c40d920635dbcaef41618c
parent46c432f447f0db9848a17cad2990f1bb4ae995ad (diff)
downloadaur-65321dcaa8885506f14a8fc96e4c78e4430b9e8f.tar.gz
Changed package description size
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 118599431f50..cc11883904dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sublime-text-3-imfix
- pkgdesc = Sophisticated text editor for code, markup and prose - Stable build with input method support for CJK users
+ pkgdesc = Sophisticated text editor for code, html and prose - Stable build with support for CJK
pkgver = 3.3211
- pkgrel = 1
+ pkgrel = 2
url = https://www.sublimetext.com/3
arch = x86_64
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index 67cab9d1f04d..ec77952f1ada 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=sublime-text-3-imfix
pkgver=3.3211
pkgrel=2
-pkgdesc='Sophisticated text editor for code, markup and prose - Stable build with input method support for CJK users'
+pkgdesc="Sophisticated text editor for code, html and prose - Stable build with support for CJK"
arch=('x86_64')
url='https://www.sublimetext.com/3'
license=('custom')
@@ -19,20 +19,24 @@ sha256sums=('0b3c8ca5e6df376c3c24a4b9ac2e3b391333f73b229bc6e87d0b4a5f636d74ee'
package() {
cd "${srcdir}"
+
# Install sublime text 3
install -dm755 "${pkgdir}/opt"
cp --preserve=mode -r "sublime_text_3" "${pkgdir}/opt/sublime_text_3"
+
# Install icons
for res in 128x128 16x16 256x256 32x32 48x48; do
install -dm755 "${pkgdir}/usr/share/icons/hicolor/${res}/apps"
ln -s "/opt/sublime_text_3/Icon/${res}/sublime-text.png" "${pkgdir}/usr/share/icons/hicolor/${res}/apps/sublime-text.png"
done
+
# Install desktop entry and executable
install -dm755 "${pkgdir}/usr/share/applications"
install -Dm644 "sublime_text_3/sublime_text.desktop" "${pkgdir}/usr/share/applications/sublime_text.desktop"
sed -i 's#/opt/sublime_text/sublime_text#subl#g' "${pkgdir}/usr/share/applications/sublime_text.desktop"
install -dm755 "${pkgdir}/usr/bin"
ln -s "/opt/sublime_text_3/sublime_text" "${pkgdir}/usr/bin/subl"
+
# Install license file
install -d "${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"