summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Bart2019-12-23 20:53:57 -0300
committerEduardo Bart2019-12-23 20:53:57 -0300
commit000ae9e65bff3889b12366a23d0236c7761f8d0f (patch)
tree100dca98ed96987e7ee50b9f9e5c8b602781c1dd
downloadaur-000ae9e65bff3889b12366a23d0236c7761f8d0f.tar.gz
Build 4061
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
-rw-r--r--sublime-text.install19
-rw-r--r--sublime_text.desktop23
4 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f224d240310
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = sublime-text-4-dev
+ pkgdesc = Sophisticated text editor for code, html and prose - dev build
+ pkgver = 4.4061
+ pkgrel = 1
+ url = http://www.sublimetext.com/
+ install = sublime-text.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = libpng
+ depends = gtk3
+ optdepends = gksu: sudo-save support
+ conflicts = sublime-text
+ source = sublime-text.install
+ source = sublime_text.desktop
+ source = https://download.sublimetext.com/sublime_text_build_4061_x64.tar.xz
+ sha256sums = 388d1fe620727bd3e6bdda7b60150734616d8ba86ef1001478d0a41d1718c018
+ sha256sums = a400ae041bd8b3ed08bf04129e1d7ddc9df9edf5610532bd7b321a43e28c7ca9
+ sha256sums = 50f6e7db86e37b7add5b2ee637ce8cffcd546d9511fdeb443eb3b3ff5ff7d021
+
+pkgname = sublime-text-4-dev
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf403aacead0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=sublime-text-4-dev
+pkgver=4.4061
+pkgrel=1
+pkgdesc="Sophisticated text editor for code, html and prose - dev build"
+arch=('i686' 'x86_64')
+url="http://www.sublimetext.com/"
+license=('custom')
+depends=('libpng' 'gtk3')
+conflicts=('sublime-text')
+optdepends=('gksu: sudo-save support')
+install=sublime-text.install
+source=("sublime-text.install"
+ "sublime_text.desktop"
+ "https://download.sublimetext.com/sublime_text_build_${pkgver:2}_x64.tar.xz")
+sha256sums=('388d1fe620727bd3e6bdda7b60150734616d8ba86ef1001478d0a41d1718c018'
+ 'a400ae041bd8b3ed08bf04129e1d7ddc9df9edf5610532bd7b321a43e28c7ca9'
+ '50f6e7db86e37b7add5b2ee637ce8cffcd546d9511fdeb443eb3b3ff5ff7d021')
+
+package() {
+ cd "${srcdir}"
+
+ install -dm755 "${pkgdir}/opt"
+ cp --preserve=mode -r "sublime_text" "${pkgdir}/opt/sublime_text"
+
+ for res in 128x128 16x16 256x256 32x32 48x48; do
+ install -dm755 "${pkgdir}/usr/share/icons/hicolor/${res}/apps"
+ ln -s "/opt/sublime_text/Icon/${res}/sublime-text.png" "${pkgdir}/usr/share/icons/hicolor/${res}/apps/sublime-text.png"
+ done
+
+ install -dm755 "${pkgdir}/usr/share/applications"
+ install -Dm644 "sublime_text.desktop" "${pkgdir}/usr/share/applications/sublime_text.desktop"
+
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s "/opt/sublime_text/sublime_text" "${pkgdir}/usr/bin/subl"
+}
diff --git a/sublime-text.install b/sublime-text.install
new file mode 100644
index 000000000000..b02fe8529bd3
--- /dev/null
+++ b/sublime-text.install
@@ -0,0 +1,19 @@
+post_install() {
+ # Update icon cache.
+ gtk-update-icon-cache -f '/usr/share/icons/hicolor' > /dev/null 2>&1
+
+ # Note admin after install/update on how to change th update_check setting.
+ cat << _EOF
+
+ ==> sublime-text-dev install/upgrade note:
+ ------------------------------------------------------------------------------
+ To disable in-application reminders about new Sublime Text dev versions,
+ add the following setting to your User Preferences file:
+ "update_check": false
+
+_EOF
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/sublime_text.desktop b/sublime_text.desktop
new file mode 100644
index 000000000000..865112df4c9f
--- /dev/null
+++ b/sublime_text.desktop
@@ -0,0 +1,23 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Sublime Text
+GenericName=Text Editor
+Comment=Sophisticated text editor for code, markup and prose
+Exec=/opt/sublime_text/sublime_text %F
+Terminal=false
+MimeType=text/plain;
+Icon=sublime-text
+Categories=TextEditor;Development;
+StartupNotify=true
+Actions=Window;Document;
+
+[Desktop Action Window]
+Name=New Window
+Exec=/opt/sublime_text/sublime_text -n
+OnlyShowIn=Unity;
+
+[Desktop Action Document]
+Name=New File
+Exec=/opt/sublime_text/sublime_text --command new_file
+OnlyShowIn=Unity \ No newline at end of file