summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Bart2020-09-23 13:46:21 -0300
committerEduardo Bart2020-09-23 13:47:31 -0300
commit102bcc511a8dbb4bc81d5e89a94efa088aa8bfaa (patch)
tree83444b23e04abcd0d8646368fec7e6ee9add76c9
parent7642739e2a798516c6b853894a64820a56e67e8b (diff)
downloadaur-102bcc511a8dbb4bc81d5e89a94efa088aa8bfaa.tar.gz
Support aarch64
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e500a3c48e6c..814c2dec16f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,7 @@ pkgbase = sublime-text-4-dev
url = http://www.sublimetext.com/
install = sublime-text.install
arch = x86_64
+ arch = aarch64
license = custom
depends = libpng
depends = gtk3
diff --git a/PKGBUILD b/PKGBUILD
index 632fdc59760a..a767fe995760 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,22 @@ pkgname=sublime-text-4-dev
pkgver=4.4086
pkgrel=1
pkgdesc="Sophisticated text editor for code, html and prose - dev build"
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="http://www.sublimetext.com/"
license=('custom')
depends=('libpng' 'gtk3')
conflicts=('sublime-text')
optdepends=('gksu: sudo-save support')
install=sublime-text.install
+case "${CARCH}" in
+ x86_64) _CARCH='x64' && sha256sums=('388d1fe620727bd3e6bdda7b60150734616d8ba86ef1001478d0a41d1718c018'
+ 'a400ae041bd8b3ed08bf04129e1d7ddc9df9edf5610532bd7b321a43e28c7ca9'
+ 'ff58895daf5e4ee8c0b2f6c08fd272d6a2c8ed353689b39668436794a92bf504');;
+ aarch64) _CARCH='arm64' && sha256sums=('SKIP' 'SKIP' 'SKIP');;
+esac
source=("sublime-text.install"
"sublime_text.desktop"
- "https://download.sublimetext.com/sublime_text_build_${pkgver:2}_x64.tar.xz")
+ "https://download.sublimetext.com/sublime_text_build_${pkgver:2}_${_CARCH}.tar.xz")
sha256sums=('388d1fe620727bd3e6bdda7b60150734616d8ba86ef1001478d0a41d1718c018'
'a400ae041bd8b3ed08bf04129e1d7ddc9df9edf5610532bd7b321a43e28c7ca9'
'ff58895daf5e4ee8c0b2f6c08fd272d6a2c8ed353689b39668436794a92bf504')