summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-04-15 11:13:50 -0600
committerMark Wagie2022-04-15 11:13:50 -0600
commit6bb57447621c785db686b8c9b5eb3619b8941a94 (patch)
treed580edb9a52a1d04069c424e953cd7d11fefad4f
parentcbbdc225ca9f86500b8c248fddecd7e8ffdd8f46 (diff)
downloadaur-6bb57447621c785db686b8c9b5eb3619b8941a94.tar.gz
standards based build
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14d4b54526e9..bd0d2861f940 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = subliminal-git
pkgdesc = Python library and CLI tool for searching and downloading subtitles.
pkgver = 2.1.0.r22.g160ea63
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/Diaoul/subliminal
arch = any
license = MIT
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
makedepends = python-sphinxcontrib-programoutput
makedepends = python-sphinx_rtd_theme
+ makedepends = python-wheel
depends = python-guessit
depends = python-babelfish
depends = python-enzyme
diff --git a/PKGBUILD b/PKGBUILD
index e0958cd2a147..f993aed443d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=subliminal-git
pkgver=2.1.0.r22.g160ea63
-pkgrel=5
+pkgrel=6
pkgdesc="Python library and CLI tool for searching and downloading subtitles."
arch=('any')
url="https://github.com/Diaoul/subliminal"
@@ -14,8 +14,8 @@ depends=('python-guessit' 'python-babelfish' 'python-enzyme' 'python-beautifuls
'python-requests' 'python-click' 'python-dogpile.cache' 'python-stevedore'
'python-chardet' 'python-pysrt' 'python-six' 'python-appdirs' 'python-rarfile'
'python-pytz' 'python-importlib_resources')
-makedepends=('git' 'python-setuptools' 'python-sphinxcontrib-programoutput'
- 'python-sphinx_rtd_theme')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools'
+ 'python-sphinxcontrib-programoutput' 'python-sphinx_rtd_theme' 'python-wheel')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://github.com/Diaoul/subliminal.git#branch=develop')
@@ -33,7 +33,7 @@ prepare() {
build() {
cd "$srcdir/${pkgname%-git}"
- python setup.py build
+ python -m build --wheel --no-isolation
cd "$srcdir/${pkgname%-git}/docs"
make man
@@ -41,8 +41,7 @@ build() {
package() {
cd "$srcdir/${pkgname%-git}"
- export PYTHONHASHSEED=0
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
install -Dm644 "docs/_build/man/${pkgname%-git}.1" -t "$pkgdir/usr/share/man/man1"