summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-04-23 07:58:16 -0600
committerMark Wagie2021-04-23 07:58:16 -0600
commit9db7ee9e21ebf948bc47e54199abe204bddc4e4f (patch)
treec55a72059e5989114ad3764db11c131d366de09c
parentc4b16f77d846f6db15f4882512c99feae334248b (diff)
downloadaur-9db7ee9e21ebf948bc47e54199abe204bddc4e4f.tar.gz
add missing dependencies
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b4d480b0054..7e3d1657e12a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = subliminal-git
pkgdesc = Python library and CLI tool for searching and downloading subtitles.
pkgver = 2.1.0.r22.g160ea63
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Diaoul/subliminal
arch = any
license = MIT
@@ -10,12 +10,14 @@ pkgbase = subliminal-git
makedepends = python-sphinxcontrib-programoutput
makedepends = python-sphinx_rtd_theme
depends = python-guessit
+ depends = python-babelfish
depends = python-enzyme
depends = python-beautifulsoup4
depends = python-requests
depends = python-click
depends = python-dogpile.cache
depends = python-stevedore
+ depends = python-chardet
depends = python-pysrt
depends = python-six
depends = python-appdirs
diff --git a/PKGBUILD b/PKGBUILD
index a6027b678b79..0c32d142dc26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,15 @@
pkgname=subliminal-git
pkgver=2.1.0.r22.g160ea63
-pkgrel=1
+pkgrel=2
pkgdesc="Python library and CLI tool for searching and downloading subtitles."
arch=('any')
url="https://github.com/Diaoul/subliminal"
license=('MIT')
-depends=('python-guessit' 'python-enzyme' 'python-beautifulsoup4' 'python-requests'
- 'python-click' 'python-dogpile.cache' 'python-stevedore' 'python-pysrt'
- 'python-six' 'python-appdirs' 'python-rarfile' 'python-pytz')
+depends=('python-guessit' 'python-babelfish' 'python-enzyme' 'python-beautifulsoup4'
+ 'python-requests' 'python-click' 'python-dogpile.cache' 'python-stevedore'
+ 'python-chardet' 'python-pysrt' 'python-six' 'python-appdirs' 'python-rarfile'
+ 'python-pytz')
makedepends=('git' 'python-setuptools' 'python-sphinxcontrib-programoutput'
'python-sphinx_rtd_theme')
provides=("${pkgname%-git}")
@@ -40,9 +41,10 @@ build() {
package() {
cd "$srcdir/${pkgname%-git}"
+ export PYTHONHASHSEED=0
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
- install -Dm644 docs/_build/man/subliminal.1 -t "$pkgdir/usr/share/man/man1"
+ install -Dm644 "docs/_build/man/${pkgname%-git}.1" -t "$pkgdir/usr/share/man/man1"
}