aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThom Wiggers2014-12-31 15:49:23 +0100
committerThom Wiggers2014-12-31 15:49:23 +0100
commit3094d655c4c52d86eaf272198698dbb629d5783d (patch)
tree7bfb2720889642f0f173c67b61cd713188fc31bb
parent6ea4c23b83b7c24d684e3346c7b7c83398bc6a1d (diff)
downloadaur-3094d655c4c52d86eaf272198698dbb629d5783d.tar.gz
add helper makefile
-rw-r--r--Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..6d2db55ffd5d
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,16 @@
+.PHONY: package
+package: PKGBUILD subsonic-beta.install
+ makepkg -f
+
+.PHONY: source
+source: PKGBUILD subsonic-beta.install
+ makepkg --source
+
+.PHONY: clean
+clean:
+ rm -f *.tar.gz *.tar.xz *.sig
+ rm -rf pkg/ src/
+
+.PHONY: upload
+upload: clean source
+ aurploader --keep-cookiejar --auto *.src.tar.gz