summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyszard Knop2019-05-05 18:05:40 +0200
committerRyszard Knop2019-05-05 18:05:40 +0200
commitc81ef55140fa65f1d469b5b16cd611c831106913 (patch)
tree4b608c166af743b43f976d300f850b7e45af18c1
downloadaur-c81ef55140fa65f1d469b5b16cd611c831106913.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD40
-rw-r--r--substance-alchemist10
-rw-r--r--substance-alchemist-icon.pngbin0 -> 2546 bytes
-rw-r--r--substance-alchemist.desktop11
5 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95db5a64ab31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = substance-alchemist
+ pkgdesc = Experimental PBR material authoring, generation, manipulation and management tool
+ pkgver = 0.6.0.rc3
+ pkgrel = 1
+ url = https://www.allegorithmic.com/products/bitmap2material
+ arch = x86_64
+ license = custom
+ depends = fontconfig
+ depends = gcc-libs-multilib
+ depends = glu
+ depends = hicolor-icon-theme
+ depends = libtiff4
+ options = !strip
+ source = https://download.allegorithmic.com/substance-alchemist/0.x/Substance_Alchemist-0.6.0-rc.3-147-linux-x64-Release-077aeac1.rpm
+ source = substance-alchemist-icon.png
+ source = substance-alchemist.desktop
+ source = substance-alchemist
+ sha256sums = SKIP
+ sha256sums = b0c9cc1be9e784641810e163d4f580dba45c36ecc73381988317c2cec4e93276
+ sha256sums = 17350182c0f7527be52db14f3a92f8074a7ea69857d6088c198478943132c8a4
+ sha256sums = 4aabc0246f0e985d278ce5773c39b378d7b5117430c029cd4da069175c5c2c1b
+
+pkgname = substance-alchemist
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e5e51afc91d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Dragoon Aethis <dragoon@dragonic.eu>
+
+pkgname=substance-alchemist
+pkgver=0.6.0.rc3
+pkgrel=1
+
+# pkgver can't contain dashes etc, so we have to simplify that for now (until Alchemist is released for real).
+# _flavor looks like something that will change, previous packages usually had the standard-full/commercial suffix
+_version=0.6.0-rc.3
+_build=147
+_flavor=Release-077aeac1
+
+pkgdesc="Experimental PBR material authoring, generation, manipulation and management tool"
+arch=('x86_64')
+url='https://www.allegorithmic.com/products/bitmap2material'
+license=('custom')
+depends=('fontconfig' 'gcc-libs-multilib' 'glu' 'hicolor-icon-theme' 'libtiff4')
+options=('!strip')
+source=("https://download.allegorithmic.com/substance-alchemist/0.x/Substance_Alchemist-${_version}-${_build}-linux-x64-${_flavor}.rpm"
+ 'substance-alchemist-icon.png'
+ 'substance-alchemist.desktop'
+ 'substance-alchemist')
+sha256sums=('SKIP'
+ 'b0c9cc1be9e784641810e163d4f580dba45c36ecc73381988317c2cec4e93276'
+ '17350182c0f7527be52db14f3a92f8074a7ea69857d6088c198478943132c8a4'
+ '4aabc0246f0e985d278ce5773c39b378d7b5117430c029cd4da069175c5c2c1b')
+validpgpkeys=()
+
+package() {
+ mkdir -p ${pkgdir}/opt/Allegorithmic
+ mv ${srcdir}/opt/Allegorithmic/Substance_Alchemist ${pkgdir}/opt/Allegorithmic
+
+ install -Dm644 ${pkgdir}/opt/Allegorithmic/Substance_Alchemist/eula.txt \
+ ${pkgdir}/usr/share/licenses/${pkgname}/eula.txt
+ rm ${pkgdir}/opt/Allegorithmic/Substance_Alchemist/eula.txt
+
+ install -Dm644 -t "${pkgdir}/usr/share/applications" "${srcdir}/substance-alchemist.desktop"
+ install -Dm644 -t "${pkgdir}/usr/share/icons/hicolor/256x256/apps" "${srcdir}/substance-alchemist-icon.png"
+ install -Dm755 -t "${pkgdir}/usr/bin" "${srcdir}/substance-alchemist"
+}
diff --git a/substance-alchemist b/substance-alchemist
new file mode 100644
index 000000000000..75b2b2ef4e2d
--- /dev/null
+++ b/substance-alchemist
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+# If the interface is too small/big, uncomment the following line and tweak the value accordingly.
+#export QT_SCALE_FACTOR=0.75
+
+# If you're using a Nvidia Optimus setup, uncomment the line below and comment the final line to
+# always use the Nvidia GPU for this software (which is often too heavy for integrated GPUs).
+#exec primusrun /opt/Allegorithmic/Substance_Alchemist/Substance\ Alchemist "$@"
+
+exec /opt/Allegorithmic/Substance_Alchemist/Substance\ Alchemist "$@"
diff --git a/substance-alchemist-icon.png b/substance-alchemist-icon.png
new file mode 100644
index 000000000000..b61979a3c1b8
--- /dev/null
+++ b/substance-alchemist-icon.png
Binary files differ
diff --git a/substance-alchemist.desktop b/substance-alchemist.desktop
new file mode 100644
index 000000000000..4981c6fcaaf2
--- /dev/null
+++ b/substance-alchemist.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Substance Alchemist
+GenericName=Experimental PBR material editor
+Description=PBR material authoring, generation, manipulation and management tool
+Exec=/usr/bin/substance-alchemist
+Icon=substance-alchemist-icon
+Terminal=false
+Type=Application
+StartupNotify=true
+Categories=Utility;Graphics
+MimeType=application/x.allegorithmic.package;application/x.allegorithmic.substance