summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyszard Knop2017-09-07 18:27:51 +0200
committerRyszard Knop2017-09-07 18:27:51 +0200
commit5dcb0416ee616279c3186c799711898aa2d33259 (patch)
treea8f5ae42e26ed18be8263327c4fc85ffed88d9a0
parentf104ce74c248bedd3cf541fee9e1c0685179eb37 (diff)
downloadaur-5dcb0416ee616279c3186c799711898aa2d33259.tar.gz
Updated to the latest download link, prevented OptiPNG from ruining assets, updated metadata
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD20
-rw-r--r--substance-painter4
-rw-r--r--substance-painter-icon.pngbin29406 -> 19096 bytes
-rw-r--r--substance-painter.desktop7
5 files changed, 28 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf06d26c4c76..74946888343e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Fri Jul 28 15:16:38 UTC 2017
pkgbase = substance-painter
- pkgdesc = Substance Painter is a 3D painting software allowing you to texture, render and share your work.
- pkgver = 2017.2
- pkgrel = 1
+ pkgdesc = 3D painting software allowing you to texture, render and share your work.
+ pkgver = 2017.2.0
+ pkgrel = 2
url = https://www.allegorithmic.com/products/substance-painter
arch = x86_64
license = custom
@@ -13,14 +11,15 @@ pkgbase = substance-painter
depends = hicolor-icon-theme
depends = libtiff4
options = !strip
- source = https://alg-releases.s3.amazonaws.com/public_releases/substance-painter/2017.x/Substance_Painter-2017.2.0-1.el6.standard.full.x86_64.rpm
+ options = !optipng
+ source = https://download.allegorithmic.com/substance-painter/2017.x/Substance_Painter-2017.2.0-1.el6.standard.full.x86_64.rpm
source = substance-painter-icon.png
source = substance-painter.desktop
source = substance-painter
- md5sums = 21262cdec1600609edc81c11cf6013a8
- md5sums = d5715b07d3b99cc2083b9e09f9f3fb20
- md5sums = 1ca4766b0d74e3a516c9cd982fefd57a
- md5sums = 6e0609c61174fce165702694b9abd292
+ sha256sums = 940d4c3ed7458d9c6126302a8de00f28870e9b7767f898b3b99d55633d515d12
+ sha256sums = 6744c1fbe8e9fb1fb91bd291e3ef8ac645bbfec1aa97915f440e6fbfebf4edbd
+ sha256sums = 70d973bbc0459f80285a52d6054c2ac72ab2e639c4c7dc42ca1dad81ef892d1d
+ sha256sums = e736a5e160be09cfe1588d349084e2f769815687db080b8c7b790e8751f185f1
pkgname = substance-painter
diff --git a/PKGBUILD b/PKGBUILD
index 49a0c1ad564e..437953d60797 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# Maintainer: Oscar Morante <spacepluk@gmail.com>
+# Co-maintainer: Dragoon Aethis <dragoon@dragonic.eu>
pkgname=substance-painter
-pkgver=2017.2
-pkgrel=1
-pkgdesc="Substance Painter is a 3D painting software allowing you to texture, render and share your work."
+pkgver=2017.2.0
+pkgrel=2
+pkgdesc="3D painting software allowing you to texture, render and share your work."
arch=('x86_64')
url='https://www.allegorithmic.com/products/substance-painter'
license=('custom')
depends=('fontconfig' 'gcc-libs-multilib' 'glu' 'hicolor-icon-theme' 'libtiff4')
-options=('!strip')
-source=('https://alg-releases.s3.amazonaws.com/public_releases/substance-painter/2017.x/Substance_Painter-2017.2.0-1.el6.standard.full.x86_64.rpm'
+options=('!strip' '!optipng') # PNG assets here should be left untouched!
+source=('https://download.allegorithmic.com/substance-painter/2017.x/Substance_Painter-2017.2.0-1.el6.standard.full.x86_64.rpm'
'substance-painter-icon.png'
'substance-painter.desktop'
'substance-painter')
noextract=()
-md5sums=('21262cdec1600609edc81c11cf6013a8'
- 'd5715b07d3b99cc2083b9e09f9f3fb20'
- '1ca4766b0d74e3a516c9cd982fefd57a'
- '6e0609c61174fce165702694b9abd292')
+sha256sums=('940d4c3ed7458d9c6126302a8de00f28870e9b7767f898b3b99d55633d515d12'
+ '6744c1fbe8e9fb1fb91bd291e3ef8ac645bbfec1aa97915f440e6fbfebf4edbd'
+ '70d973bbc0459f80285a52d6054c2ac72ab2e639c4c7dc42ca1dad81ef892d1d'
+ 'e736a5e160be09cfe1588d349084e2f769815687db080b8c7b790e8751f185f1')
validpgpkeys=()
package() {
@@ -31,4 +32,3 @@ package() {
install -Dm644 -t "${pkgdir}/usr/share/icons/hicolor/256x256/apps" "${srcdir}/substance-painter-icon.png"
install -Dm755 -t "${pkgdir}/usr/bin" "${srcdir}/substance-painter"
}
-
diff --git a/substance-painter b/substance-painter
index 77bc66c8029d..0d1627ec48eb 100644
--- a/substance-painter
+++ b/substance-painter
@@ -1,7 +1,11 @@
#!/bin/sh
+# If the interface is too small/big, uncomment the following line and tweak the value accordingly.
#export QT_SCALE_FACTOR=0.75
+# If you're using a Nvidia Optimus setup, uncomment the line below and comment the final line to
+# always use the Nvidia GPU for this software (which is often too heavy for integrated GPUs).
#exec primusrun /opt/Allegorithmic/Substance_Painter/Substance\ Painter "$@"
+
exec /opt/Allegorithmic/Substance_Painter/Substance\ Painter "$@"
diff --git a/substance-painter-icon.png b/substance-painter-icon.png
index fb191f7186db..48ab19ebfce3 100644
--- a/substance-painter-icon.png
+++ b/substance-painter-icon.png
Binary files differ
diff --git a/substance-painter.desktop b/substance-painter.desktop
index c2b4e9f2c59e..36f1699f7c30 100644
--- a/substance-painter.desktop
+++ b/substance-painter.desktop
@@ -1,9 +1,12 @@
[Desktop Entry]
Name=Substance Painter
+GenericName=3D Painting/Texturing Software
+Description=3D painting software for PBR model texturing and rendering
Exec=/usr/bin/substance-painter
Icon=substance-painter-icon
+Version=2017.2.0
Terminal=false
Type=Application
StartupNotify=true
-Categories=Graphics
-
+Categories=Utility;Graphics
+MimeType=application/x.allegorithmic.package+xml;application/x.allegorithmic.substance