summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2019-06-04 20:36:38 -1000
committerGaetan Bisson2019-06-04 20:36:38 -1000
commit19f912a13fc4eace231fa77ea542524143e75d35 (patch)
tree65b3413e96eafb2cb3baae63e286ec10a0d3b61c
parent4ef03e87309c2da615d9e2c4595d813c29aa26e0 (diff)
downloadaur-19f912a13fc4eace231fa77ea542524143e75d35.tar.gz
upstream update, fix error: expected unqualified-id before 'namespace'
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
-rw-r--r--semicolon.patch12
3 files changed, 25 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 621d46559b50..086318b1bb7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = subsurface-git
pkgdesc = Divelog program
- pkgver = 20180621.693604753
+ pkgver = 20190603.a592b4e14
pkgrel = 1
url = https://subsurface-divelog.org/
arch = i686
@@ -26,7 +26,9 @@ pkgbase = subsurface-git
provides = subsurface
conflicts = subsurface
source = git+https://github.com/Subsurface-divelog/subsurface
+ source = semicolon.patch
sha256sums = SKIP
+ sha256sums = ebf7a7e3690254a257ff9094a1298b7d070abe8cf95c03ea21d78ec710972060
pkgname = subsurface-git
diff --git a/PKGBUILD b/PKGBUILD
index 6c6f68cf8651..aa15c0c32f5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=subsurface-git
_pkgname=subsurface
-pkgver=20180621.693604753
+pkgver=20190603.a592b4e14
pkgrel=1
pkgdesc='Divelog program'
url='https://subsurface-divelog.org/'
@@ -13,8 +13,10 @@ makedepends=('git' 'cmake' 'asciidoc' 'qt5-tools')
depends=('libzip' 'libxml2' 'libxslt' 'sqlite' 'libusb' 'libgit2'
'subsurface-libdc-git' 'qt5-svg' 'qt5-location'
'qt5-connectivity' 'qt5-webkit' 'grantlee' 'googlemaps')
-source=('git+https://github.com/Subsurface-divelog/subsurface')
-sha256sums=('SKIP')
+source=('git+https://github.com/Subsurface-divelog/subsurface'
+ 'semicolon.patch')
+sha256sums=('SKIP'
+ 'ebf7a7e3690254a257ff9094a1298b7d070abe8cf95c03ea21d78ec710972060')
# qt5-webkit still used for: printing, manual, facebook
@@ -26,11 +28,13 @@ pkgver() {
git log -1 --format='%cd.%h' --date=short | tr -d -
}
-build() {
+prepare() {
cd "${srcdir}/${_pkgname}"
- git revert -n a76f15f0f67c3f138362ec8c503f645dc1211cf5
- git revert -n d21d42b69117aae04b68ecc9cc2139e034bde146
+ sudo patch /usr/include/qt/QtQml/qqmlprivate.h ../semicolon.patch
+}
+build() {
+ cd "${srcdir}/${_pkgname}"
install -d build
cd build
cmake \
diff --git a/semicolon.patch b/semicolon.patch
new file mode 100644
index 000000000000..b3a5f5c9303f
--- /dev/null
+++ b/semicolon.patch
@@ -0,0 +1,12 @@
+diff -Naur /usr/include/qt/QtQml/qqmlprivate.h /usr/include/qt/QtQml/qqmlprivate.h
+--- /usr/include/qt/QtQml/qqmlprivate.h 2019-06-04 19:46:26.474390128 -1000
++++ /usr/include/qt/QtQml/qqmlprivate.h 2019-06-04 19:46:33.337543945 -1000
+@@ -68,7 +68,7 @@
+ namespace CompiledData {
+ struct Unit;
+ struct CompilationUnit;
+-}
++};
+ }
+ namespace QmlIR {
+ struct Document;