summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2017-04-04 13:49:43 -1000
committerGaetan Bisson2017-04-04 13:49:43 -1000
commit8697d698116895579b0b5c944ae93f24e5712762 (patch)
treebe8dfab6d1d7ce0c8d013d942d5f18e45184b337
parent203dccbd08006b37cdfdb8ad9f9666e39fca1c73 (diff)
downloadaur-8697d698116895579b0b5c944ae93f24e5712762.tar.gz
fix build with recent gcc/qt
-rw-r--r--PKGBUILD9
-rw-r--r--headers.patch24
2 files changed, 30 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 421fc03c8705..440ac3ccb967 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=subsurface-git
_pkgname=subsurface
-pkgver=20170329.09b5f9b9
+pkgver=20170403.8c94fa26
pkgrel=1
pkgdesc='Divelog program'
url='https://subsurface-divelog.org/'
@@ -13,8 +13,10 @@ makedepends=('git' 'cmake' 'asciidoc')
depends=('libzip' 'libxml2' 'libxslt' 'sqlite' 'libusb' 'libgit2'
'subsurface-libdc' 'subsurface-marble'
'qt5-connectivity' 'grantlee')
-source=('git://git.subsurface-divelog.org/subsurface')
-sha256sums=('SKIP')
+source=('git://git.subsurface-divelog.org/subsurface'
+ 'headers.patch')
+sha256sums=('SKIP'
+ 'fbcbf99294e9ba9ef134eb04b832cca4b19355070020f5ee2984ce739e8f0a6c')
provides=('subsurface')
conflicts=('subsurface')
@@ -27,6 +29,7 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
sed 's:<marble:<subsurface/marble:g' -i desktop-widgets/globe.*
+ patch -p1 -i ../headers.patch
}
build() {
diff --git a/headers.patch b/headers.patch
new file mode 100644
index 000000000000..a7327520064c
--- /dev/null
+++ b/headers.patch
@@ -0,0 +1,24 @@
+diff --git a/desktop-widgets/printer.cpp b/desktop-widgets/printer.cpp
+index 1ea275cf..25d3ceeb 100644
+--- a/desktop-widgets/printer.cpp
++++ b/desktop-widgets/printer.cpp
+@@ -3,6 +3,7 @@
+ #include "core/statistics.h"
+ #include "core/helpers.h"
+
++#include <QtMath>
+ #include <algorithm>
+ #include <QPainter>
+ #ifdef USE_WEBENGINE
+diff --git a/desktop-widgets/printer.h b/desktop-widgets/printer.h
+index fc867bb3..f7299f01 100644
+--- a/desktop-widgets/printer.h
++++ b/desktop-widgets/printer.h
+@@ -1,6 +1,7 @@
+ #ifndef PRINTER_H
+ #define PRINTER_H
+
++#include <QPointer>
+ #include <QPrinter>
+ #ifdef USE_WEBENGINE
+ #include <QWebEngineView>