summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2015-06-15 15:11:14 -1000
committerGaetan Bisson2015-06-15 15:11:14 -1000
commita93cb57690eb94a591f9892a7db786cffdc98624 (patch)
treed51be3acb3d170f110626cd323e0d25506c93382
downloadaur-a93cb57690eb94a591f9892a7db786cffdc98624.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ecd10c9e52c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = subsurface-libdc-git
+ pkgdesc = Library for communication with dive computers
+ pkgver = 20150614.692377e
+ pkgrel = 1
+ url = http://git.subsurface-divelog.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ provides = subsurface-libdc
+ conflicts = subsurface-libdc
+ source = git://git.subsurface-divelog.org/libdc#branch=Subsurface-testing
+ sha1sums = SKIP
+
+pkgname = subsurface-libdc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73c681e1dffc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributor: Francois Boulogne <fboulogne at april dot org>
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=subsurface-libdc-git
+_pkgname=libdc
+pkgver=20150614.692377e
+pkgrel=1
+pkgdesc='Library for communication with dive computers'
+url='http://git.subsurface-divelog.org/'
+license=('LGPL')
+arch=('i686' 'x86_64')
+makedepends=('git')
+source=('git://git.subsurface-divelog.org/libdc#branch=Subsurface-testing')
+sha1sums=('SKIP')
+
+conflicts=('subsurface-libdc')
+provides=('subsurface-libdc')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ autoreconf --install
+ ./configure \
+ --prefix=/usr \
+ --program-prefix="${_pkgname}-" \
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+}