summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-08-16 16:58:31 -0600
committerMark Wagie2021-08-16 16:58:31 -0600
commit5ba62c3d40dae1641dd32bceec674b51cf404149 (patch)
tree5a10f39263dee4fb8e3fc688f01114e936c5428d
parentf057a57569a7293206c043510efbd3751b615c6e (diff)
downloadaur-5ba62c3d40dae1641dd32bceec674b51cf404149.tar.gz
initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD34
3 files changed, 44 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e5b323e2fbd..177844cbb765 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,21 @@
pkgbase = subsync
- pkgdesc = Automagically synchronize subtitles with video
- pkgver = 0.2.4
+ pkgdesc = Subtitle Speech Synchronizer
+ pkgver = 0.16
pkgrel = 1
- url = https://github.com/smacke/subsync
- arch = any
- license = MIT
- makedepends = python-pip
- source = https://github.com/smacke/subsync/archive/master.zip
- md5sums = 1c1bbb4ad2870194a489043eef63f8b9
+ url = https://subsync.online
+ arch = x86_64
+ license = GPL3
+ makedepends = python-setuptools
+ depends = ffmpeg
+ depends = pocketsphinx
+ depends = pybind11
+ depends = python-certifi
+ depends = python-cryptography
+ depends = python-pysubs2
+ depends = python-pyaml
+ depends = python-requests
+ depends = python-wxpython
+ source = subsync-0.16.tar.gz::https://github.com/sc0ty/subsync/archive/refs/tags/0.16.tar.gz
+ sha256sums = bdbfc0504b6dd036bb238daaa863016ed157c810edde5c4fc5e50a28cee309f2
pkgname = subsync
-
diff --git a/.gitignore b/.gitignore
index 241e560df690..4dab8d6386e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,7 @@
+# Ignore everything
*
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 4ebeb4affcae..18b5e9bcd891 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,27 @@
-# Maintainer: Thulinma <jaron@vietors.com>
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=subsync
-pkgdesc="Automagically synchronize subtitles with video"
-pkgver=0.2.4
+pkgver=0.16
pkgrel=1
-license=('MIT')
-arch=('any')
-url="https://github.com/smacke/subsync"
-makedepends=('python-pip')
-source=("https://github.com/smacke/subsync/archive/master.zip")
-md5sums=('1c1bbb4ad2870194a489043eef63f8b9')
+pkgdesc="Subtitle Speech Synchronizer"
+arch=('x86_64')
+url="https://subsync.online"
+license=('GPL3')
+depends=('ffmpeg' 'pocketsphinx' 'pybind11' 'python-certifi' 'python-cryptography'
+ 'python-pysubs2' 'python-pyaml' 'python-requests' 'python-wxpython')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/sc0ty/subsync/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('bdbfc0504b6dd036bb238daaa863016ed157c810edde5c4fc5e50a28cee309f2')
-package() {
- cd "$srcdir/subsync-master"
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps subsync
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
}
+package() {
+ cd "$pkgname-$pkgver"
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm644 "resources/$pkgname.desktop" -t "$pkgdir/usr/share/applications"
+ install -Dm644 "resources/$pkgname.svg" -t "$pkgdir/usr/share/icons/hicolor/scalable/apps"
+}