summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-05-29 11:44:30 -0600
committerMark Wagie2022-05-29 11:44:30 -0600
commita4ede01572abe58aa05e3a419beede2ebbb2380d (patch)
tree734c6fe71d4f08cb9de413a3a4d0edba72cdb0f7
parent2419c4cc5c5d6314cf651e0d16b6e47843e0c23e (diff)
downloadaur-a4ede01572abe58aa05e3a419beede2ebbb2380d.tar.gz
use git commit hash instead of tag, correct deps
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7af7ad482e58..9342332f34c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = subsync
pkgdesc = Subtitle Speech Synchronizer
pkgver = 0.17
- pkgrel = 4
+ pkgrel = 5
url = https://subsync.online
arch = x86_64
license = GPL3
+ makedepends = git
makedepends = python-setuptools
depends = ffmpeg4.4
- depends = git
depends = pocketsphinx
depends = pybind11
depends = python-certifi
@@ -16,7 +16,7 @@ pkgbase = subsync
depends = python-pyaml
depends = python-requests
depends = python-wxpython
- source = git+https://github.com/sc0ty/subsync.git#tag=0.17
+ source = git+https://github.com/sc0ty/subsync.git#commit=be5390d00ff475b6543eb0140c7e65b34317d95b
sha256sums = SKIP
pkgname = subsync
diff --git a/PKGBUILD b/PKGBUILD
index 728d6a7c8c6a..f4c90e9b700b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=subsync
pkgver=0.17
-pkgrel=4
+pkgrel=5
pkgdesc="Subtitle Speech Synchronizer"
arch=('x86_64')
url="https://subsync.online"
license=('GPL3')
-depends=('ffmpeg4.4' 'git' 'pocketsphinx' 'pybind11' 'python-certifi' 'python-cryptography'
+depends=('ffmpeg4.4' 'pocketsphinx' 'pybind11' 'python-certifi' 'python-cryptography'
'python-pysubs2' 'python-pyaml' 'python-requests' 'python-wxpython')
-makedepends=('python-setuptools')
-source=("git+https://github.com/sc0ty/subsync.git#tag=$pkgver")
+makedepends=('git' 'python-setuptools')
+_commit=be5390d00ff475b6543eb0140c7e65b34317d95b
+source=("git+https://github.com/sc0ty/subsync.git#commit=${_commit}")
sha256sums=('SKIP')
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed 's/-/+/g'
+}
+
build() {
cd "$srcdir/$pkgname"
export PKG_CONFIG_PATH='/usr/lib/ffmpeg4.4/pkgconfig'