summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-06-10 21:47:05 +0200
committerMartchus2018-06-10 21:47:05 +0200
commit2a233ca663622ff45968612db76dcf48660dab3f (patch)
tree3ebd221809504de926106a5c22a0b8a60506989c
parent1f60356e87b7025e3b002a1cba29693f260a0df9 (diff)
downloadaur-2a233ca663622ff45968612db76dcf48660dab3f.tar.gz
Rebuild against new libav libs, add patch for Qt 5.11.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c936003c287..6945197d03ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = subtitlecomposer
pkgdesc = A KDE subtitle editor
pkgver = 0.6.6
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/maxrd2/subtitlecomposer
arch = i686
arch = x86_64
@@ -9,7 +9,6 @@ pkgbase = subtitlecomposer
makedepends = extra-cmake-modules
makedepends = xine-lib
makedepends = mpv
- makedepends = pocketsphinx
depends = kcoreaddons
depends = sonnet
depends = kcodecs
@@ -20,12 +19,13 @@ pkgbase = subtitlecomposer
optdepends = mplayer: MPlayer backend
optdepends = mpv: MPV backend
optdepends = xine-lib: Xine backend
- optdepends = pocketsphinx: speech recognition
optdepends = kross-interpreters: for ruby and python scripting support
optdepends = ruby: scripting
optdepends = python: scripting
source = https://github.com/maxrd2/subtitlecomposer/archive/v0.6.6.tar.gz
+ source = 0001-Use-target_link_libraries-instead-of-qt5_use_modules.patch::https://github.com/Martchus/subtitlecomposer/commit/cca0ff13c5bab516c073f9457277bdbf5fe1fd9a.patch
sha256sums = 6cd1d74f7934cdaa5d492f47da4143bd096a6196f2afcb2827cada9a3cdb2ea4
+ sha256sums = 8952257e4798ba009e721a1a8b5f929b03de8e733dbfa201b20fd8edd83cea99
pkgname = subtitlecomposer
diff --git a/PKGBUILD b/PKGBUILD
index 66651cca661b..4312b4de3903 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgname=subtitlecomposer
pkgver=0.6.6
-pkgrel=2
+pkgrel=3
pkgdesc="A KDE subtitle editor"
arch=('i686' 'x86_64')
url="https://github.com/maxrd2/${pkgname}"
@@ -25,19 +25,26 @@ makedepends=('extra-cmake-modules')
# building the plugins for MPV and Xine player backends and pocketsphinx
makedepends+=('xine-lib')
makedepends+=('mpv')
-makedepends+=('pocketsphinx')
+#makedepends+=('pocketsphinx')
# For consistency, also enable/disable the corresponding optdepends
optdepends=('mplayer: MPlayer backend'
'mpv: MPV backend'
'xine-lib: Xine backend'
- 'pocketsphinx: speech recognition'
+# 'pocketsphinx: speech recognition'
'kross-interpreters: for ruby and python scripting support'
'ruby: scripting'
'python: scripting')
-source=("https://github.com/maxrd2/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('6cd1d74f7934cdaa5d492f47da4143bd096a6196f2afcb2827cada9a3cdb2ea4')
+source=("https://github.com/maxrd2/${pkgname}/archive/v${pkgver}.tar.gz"
+ '0001-Use-target_link_libraries-instead-of-qt5_use_modules.patch::https://github.com/Martchus/subtitlecomposer/commit/cca0ff13c5bab516c073f9457277bdbf5fe1fd9a.patch')
+sha256sums=('6cd1d74f7934cdaa5d492f47da4143bd096a6196f2afcb2827cada9a3cdb2ea4'
+ '8952257e4798ba009e721a1a8b5f929b03de8e733dbfa201b20fd8edd83cea99')
+
+prepare() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -p1 -i "$srcdir/0001-Use-target_link_libraries-instead-of-qt5_use_modules.patch"
+}
build() {
cd ${srcdir}/${pkgname}-${pkgver}