summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMladen Milinkovic2021-11-04 00:12:02 +0100
committerMladen Milinkovic2021-11-04 00:12:02 +0100
commit3acceef8d41779a70d9d18279190650eec24f414 (patch)
treeebd98fba46897a05fecb1e25dfac05b66b61f045
parentca54d4dd6a60203a22c748907c19b3d1555b8c53 (diff)
downloadaur-3acceef8d41779a70d9d18279190650eec24f414.tar.gz
Fixed dependencies/build
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD54
2 files changed, 31 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4006300cbf88..1c0d569ee72a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,26 @@
pkgbase = subtitlecomposer
pkgdesc = Video subtitle editor
pkgver = 0.7.1
- pkgrel = 1
- url = https://invent.kde.org/kde/subtitlecomposer
+ pkgrel = 2
+ url = https://invent.kde.org/multimedia/
arch = i686
arch = x86_64
license = GPL
makedepends = extra-cmake-modules
- makedepends = xine-lib
- makedepends = mpv
+ makedepends = jack
+ makedepends = blas
+ makedepends = xorg-server-xvfb
makedepends = pocketsphinx
depends = kcoreaddons
+ depends = ktextwidgets
+ depends = kio
depends = sonnet
depends = kcodecs
depends = kross
depends = kxmlgui
depends = ki18n
depends = ffmpeg
- optdepends = gstreamer: GStreamer videoplayer backend
- optdepends = mpv: MPV videoplayer backend
- optdepends = mplayer: MPlayer videoplayer backend
- optdepends = phonon-qt5: Phonon videoplayer backend
- optdepends = xine-lib: Xine videoplayer backend
+ depends = openal
optdepends = pocketsphinx: Pocketsphinx speech recognition backend
optdepends = kross-interpreters: Ruby and Python scripting support
optdepends = ruby: scripting
diff --git a/PKGBUILD b/PKGBUILD
index ed878a3a327d..7d97d12dc287 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,53 @@
# Maintainer: Martchus <martchus@gmx.net>
# Contributor: Mladen Milinkovic <maxrd2@smoothware.net>
-# You can install/update Subtitle Composer from repository
-# if you add following to /etc/pacman.conf (x86_64 only)
-# [subtitlecomposer]
-# # Subtitle Composer
-# SigLevel = PackageRequired
-# Server = http://smoothware.net/$repo/$arch
-
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of (another) binary repository (i686 and x86_64).
+# Official arch linux binaries: https://subtitlecomposer.kde.org/download.html
+
pkgname=subtitlecomposer
pkgver=0.7.1
-pkgrel=1
+pkgrel=2
pkgdesc='Video subtitle editor'
arch=('i686' 'x86_64')
-url="https://invent.kde.org/kde/${pkgname}"
+url="https://invent.kde.org/multimedia/${_name}"
license=('GPL')
-depends=('kcoreaddons' 'sonnet' 'kcodecs' 'kross' 'kxmlgui' 'ki18n' 'ffmpeg')
-makedepends=('extra-cmake-modules')
+depends=('kcoreaddons' 'ktextwidgets' 'kio' 'sonnet' 'kcodecs' 'kross' 'kxmlgui' 'ki18n' 'ffmpeg' 'openal')
+makedepends=('extra-cmake-modules' 'jack' 'blas' 'xorg-server-xvfb')
-# Comment/uncomment the following dependencies to disable/enable
-# building the plugins for MPV and Xine player backends and pocketsphinx
-makedepends+=('xine-lib')
-makedepends+=('mpv')
+# Comment/uncomment the following dependency to disable/enable
+# building the pocketsphinx plugin
makedepends+=('pocketsphinx')
# For consistency, also enable/disable the corresponding optdepends
-optdepends=('gstreamer: GStreamer videoplayer backend'
- 'mpv: MPV videoplayer backend'
- 'mplayer: MPlayer videoplayer backend'
- 'phonon-qt5: Phonon videoplayer backend'
- 'xine-lib: Xine videoplayer backend'
- 'pocketsphinx: Pocketsphinx speech recognition backend'
+optdepends=('pocketsphinx: Pocketsphinx speech recognition backend'
'kross-interpreters: Ruby and Python scripting support'
'ruby: scripting'
'python: scripting')
-source=("https://download.kde.org/stable/${pkgname}/${pkgname}-${pkgver}.tar.xz"
- "https://download.kde.org/stable/${pkgname}/${pkgname}-${pkgver}.tar.xz.sig")
+_tar=${pkgname}-${pkgver}
+source=("https://download.kde.org/stable/${pkgname}/${_tar}.tar.xz"
+ "https://download.kde.org/stable/${pkgname}/${_tar}.tar.xz.sig")
sha256sums=('ef9cb3c0c1fe1f40cf9d8e795859b9b28adf2da3be77a076d46bc28df4cd0255'
'SKIP')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- cmake \
+ cmake -S "${srcdir}/${_tar}" -B "${srcdir}/build" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_INSTALL_LIBDIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
- -DBUILD_TESTING=OFF \
- -S . -B build
- cmake --build build
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ cmake --build "${srcdir}/build"
+}
+
+check() {
+ export DISPLAY=:99
+ Xvfb :99 >& /dev/null &
+ trap "kill $! || true" EXIT
+ cmake --build "${srcdir}/build" --target test
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- DESTDIR="${pkgdir}" cmake --install build
+ DESTDIR="${pkgdir}" cmake --install "${srcdir}/build"
}