summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMladen Milinkovic2019-06-27 21:03:11 +0200
committerMladen Milinkovic2019-06-27 21:03:11 +0200
commit51c1b061139e68f066b7df4c4bf8e31db5b56f91 (patch)
treea2d6ba7fc781353deef858ea84b60a05abe9fe08
parent9654efd3715a04b63069d55523e2d094140dd4b8 (diff)
downloadaur-51c1b061139e68f066b7df4c4bf8e31db5b56f91.tar.gz
Update to 0.7.0
-rw-r--r--PKGBUILD42
1 files changed, 23 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e77445bb7810..51902b12dfb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,53 +11,57 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of (another) binary repository (i686 and x86_64).
-pkgname=subtitlecomposer
-pkgver=0.6.6
-pkgrel=6
+_name=SubtitleComposer
+pkgname=${_name,,}
+pkgver=0.7.0
+pkgrel=1
pkgdesc="A KDE subtitle editor"
arch=('i686' 'x86_64')
-url="https://github.com/maxrd2/${pkgname}"
+url="https://github.com/maxrd2/${_name}"
license=('GPL')
-depends=('kcoreaddons' 'sonnet' 'kcodecs' 'kross' 'kxmlgui' 'ki18n' 'gstreamer')
+depends=('kcoreaddons' 'sonnet' 'kcodecs' 'kross' 'kxmlgui' 'ki18n' 'ffmpeg')
makedepends=('extra-cmake-modules')
# Comment/uncomment the following dependencies to disable/enable
# building the plugins for MPV and Xine player backends and pocketsphinx
makedepends+=('xine-lib')
makedepends+=('mpv')
-#makedepends+=('pocketsphinx')
+makedepends+=('pocketsphinx')
# For consistency, also enable/disable the corresponding optdepends
-optdepends=('mplayer: MPlayer backend'
- 'mpv: MPV backend'
- 'xine-lib: Xine backend'
-# 'pocketsphinx: speech recognition'
- 'kross-interpreters: for ruby and python scripting support'
+optdepends=('gstreamer: GStreamer videoplayer backend'
+ 'mpv: MPV videoplayer backend'
+ 'mplayer: MPlayer videoplayer backend'
+ 'phonon-qt5: Phonon videoplayer backend'
+ 'xine-lib: Xine videoplayer backend'
+ 'pocketsphinx: Pocketsphinx speech recognition backend'
+ 'kross-interpreters: Ruby and Python scripting support'
'ruby: scripting'
'python: scripting')
source=("https://github.com/maxrd2/${pkgname}/archive/v${pkgver}.tar.gz"
'0001-Use-target_link_libraries-instead-of-qt5_use_modules.patch::https://github.com/Martchus/subtitlecomposer/commit/cca0ff13c5bab516c073f9457277bdbf5fe1fd9a.patch')
-sha256sums=('8c957db7078676636f05e798219ff1052a52014ce7593dc660c345196f803ae4'
+sha256sums=('90dee806df0ee57f4098d417f62014b4533dbf5598d5535c9da1066536c1ed41'
'8952257e4798ba009e721a1a8b5f929b03de8e733dbfa201b20fd8edd83cea99')
-prepare() {
- cd ${srcdir}/${pkgname}-${pkgver}
- patch -p1 -i "$srcdir/0001-Use-target_link_libraries-instead-of-qt5_use_modules.patch"
-}
+#prepare() {
+# cd ${srcdir}/${_name}-${pkgver}
+# patch -p1 -i "$srcdir/0001-Use-target_link_libraries-instead-of-qt5_use_modules.patch"
+#}
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${srcdir}/${_name}-${pkgver}
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_INSTALL_LIBDIR=lib \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
- -DBUILD_TESTING=OFF
+ -DBUILD_TESTING=OFF \
+ -DAPP_VERSION="${pkgver}"
make
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${srcdir}/${_name}-${pkgver}
make DESTDIR=${pkgdir} install
}