summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMladen Milinkovic2021-11-03 23:57:56 +0100
committerMladen Milinkovic2021-11-03 23:57:56 +0100
commitca54d4dd6a60203a22c748907c19b3d1555b8c53 (patch)
treea329b922be481718b2a43d022ef9fdb3de00efd6
parentcb536d9590afa026c55832c271733f0516ebd14c (diff)
downloadaur-ca54d4dd6a60203a22c748907c19b3d1555b8c53.tar.gz
Updated download URL
Archive from download.kde.org also includes i18n, invent.kde.org doesn't
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 340d440465c8..4006300cbf88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -26,7 +26,9 @@ pkgbase = subtitlecomposer
optdepends = kross-interpreters: Ruby and Python scripting support
optdepends = ruby: scripting
optdepends = python: scripting
- source = https://invent.kde.org/kde/subtitlecomposer/-/archive/v0.7.1/subtitlecomposer-v0.7.1.tar.bz2
- sha256sums = d7834346525813c3d5762c45fdbea2ef49c2db7d07af86b779b376e04c982e88
+ source = https://download.kde.org/stable/subtitlecomposer/subtitlecomposer-0.7.1.tar.xz
+ source = https://download.kde.org/stable/subtitlecomposer/subtitlecomposer-0.7.1.tar.xz.sig
+ sha256sums = ef9cb3c0c1fe1f40cf9d8e795859b9b28adf2da3be77a076d46bc28df4cd0255
+ sha256sums = SKIP
pkgname = subtitlecomposer
diff --git a/PKGBUILD b/PKGBUILD
index b4e2e6b980ce..ed878a3a327d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,22 +38,24 @@ optdepends=('gstreamer: GStreamer videoplayer backend'
'ruby: scripting'
'python: scripting')
-source=("https://invent.kde.org/kde/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.bz2")
-sha256sums=('d7834346525813c3d5762c45fdbea2ef49c2db7d07af86b779b376e04c982e88')
+source=("https://download.kde.org/stable/${pkgname}/${pkgname}-${pkgver}.tar.xz"
+ "https://download.kde.org/stable/${pkgname}/${pkgname}-${pkgver}.tar.xz.sig")
+sha256sums=('ef9cb3c0c1fe1f40cf9d8e795859b9b28adf2da3be77a076d46bc28df4cd0255'
+ 'SKIP')
build() {
- cd "${srcdir}/${pkgname}-v${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_INSTALL_LIBDIR=lib \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-DBUILD_TESTING=OFF \
- -DAPP_VERSION="${pkgver}"
- make
+ -S . -B build
+ cmake --build build
}
package() {
- cd "${srcdir}/${pkgname}-v${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ DESTDIR="${pkgdir}" cmake --install build
}