summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-01-25 18:21:17 +0100
committerMartchus2022-01-25 18:21:17 +0100
commite4ccd9daa5686042adf1fec4f96be10fd80e5be1 (patch)
tree08ae69c10f360e5b7b30ec0bb44404485f97136d
parenta867dafcdad501e14b68aed3840007403fdaed13 (diff)
downloadaur-e4ccd9daa5686042adf1fec4f96be10fd80e5be1.tar.gz
Add patch for ffmpeg 5 support
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ff7f51ec0bc..9f7ec0a12f6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -26,8 +26,10 @@ pkgbase = subtitlecomposer
optdepends = python: scripting
source = https://download.kde.org/stable/subtitlecomposer/subtitlecomposer-0.7.1.tar.xz
source = https://download.kde.org/stable/subtitlecomposer/subtitlecomposer-0.7.1.tar.xz.sig
+ source = https://invent.kde.org/multimedia/subtitlecomposer/-/commit/4f4f560e40ba0b760cf688eb024be3cc734ca347.patch
validpgpkeys = 76F79007A54A4B68F1547928E2418746EF9D9B26
sha256sums = ef9cb3c0c1fe1f40cf9d8e795859b9b28adf2da3be77a076d46bc28df4cd0255
sha256sums = SKIP
+ sha256sums = 26197260a6e4419c7178c65a5ac9e8811418e40c97454b2aa8a62b149305dcd5
pkgname = subtitlecomposer
diff --git a/PKGBUILD b/PKGBUILD
index 3d34050b1c6b..5730a23c8bdc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,11 +27,18 @@ optdepends=('pocketsphinx: Pocketsphinx speech recognition backend'
_tar=${pkgname}-${pkgver}
source=("https://download.kde.org/stable/${pkgname}/${_tar}.tar.xz"
- "https://download.kde.org/stable/${pkgname}/${_tar}.tar.xz.sig")
+ "https://download.kde.org/stable/${pkgname}/${_tar}.tar.xz.sig"
+ "https://invent.kde.org/multimedia/subtitlecomposer/-/commit/4f4f560e40ba0b760cf688eb024be3cc734ca347.patch")
sha256sums=('ef9cb3c0c1fe1f40cf9d8e795859b9b28adf2da3be77a076d46bc28df4cd0255'
- 'SKIP')
+ 'SKIP'
+ '26197260a6e4419c7178c65a5ac9e8811418e40c97454b2aa8a62b149305dcd5')
validpgpkeys=('76F79007A54A4B68F1547928E2418746EF9D9B26')
+prepare() {
+ cd "${srcdir}/${_tar}"
+ patch -p1 -i "$srcdir/4f4f560e40ba0b760cf688eb024be3cc734ca347.patch"
+}
+
build() {
cmake -S "${srcdir}/${_tar}" -B "${srcdir}/build" \
-DCMAKE_BUILD_TYPE=Release \