summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNocifer2023-05-14 11:21:56 +0300
committerNocifer2023-05-14 11:21:56 +0300
commit646c1c3534c906294ff9cfd704ceb635468cd0e8 (patch)
treec99c998f72f6ddf4ec4e81e59d8b9118399fc030
parent4c64403da0d81c7c227620436b580b21e01a5710 (diff)
downloadaur-646c1c3534c906294ff9cfd704ceb635468cd0e8.tar.gz
v=3.6.13,r=1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD26
2 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1591ca7da075..b7db9693a7da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = subtitleedit
pkgdesc = An advanced subtitle editor and converter
- pkgver = 3.6.12
+ pkgver = 3.6.13
pkgrel = 1
url = https://www.nikse.dk/SubtitleEdit
arch = any
@@ -10,12 +10,13 @@ pkgbase = subtitleedit
optdepends = vlc: Video support
optdepends = mpv: Video support
optdepends = tesseract: OCR support
- noextract = SE3612.zip
- source = https://github.com/SubtitleEdit/subtitleedit/releases/download/3.6.12/SE3612.zip
+ optdepends = ffmpeg: Waveform extraction
+ noextract = SE3613.zip
+ source = https://github.com/SubtitleEdit/subtitleedit/releases/download/3.6.13/SE3613.zip
source = subtitleedit
source = subtitleedit.desktop
source = subtitleedit.png
- sha256sums = b43b1cb2041810a321bb3e3719d2684a10e515b0e8bbebff9f28d9659eae79ec
+ sha256sums = 39a7ba25f8f50f55e5289c89a040b5a8c392714b2d7954694045022da2bf209e
sha256sums = 51ae2411ed70a40607a78dd863db98bf5692bfaff7f8c230ddf82f0dc78d1cc3
sha256sums = 54ffb47864611c6aebb29ecfabd49089cfe6decc320e3f25043c39ec7f27a5fb
sha256sums = 700d09858ac76341054d7edc79952fbfca70df674d2b567e3713579e5963f631
diff --git a/PKGBUILD b/PKGBUILD
index 9b8ac780ca4d..9cee9d154d36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: eduardosm
pkgname=subtitleedit
-pkgver=3.6.12
+pkgver=3.6.13
pkgrel=1
pkgdesc='An advanced subtitle editor and converter'
arch=('any')
@@ -11,30 +11,28 @@ license=('GPL3')
depends=('mono')
optdepends=('vlc: Video support'
'mpv: Video support'
- 'tesseract: OCR support')
+ 'tesseract: OCR support'
+ 'ffmpeg: Waveform extraction')
makedepends=('unzip')
source=("https://github.com/SubtitleEdit/subtitleedit/releases/download/$pkgver/SE${pkgver//./}.zip"
'subtitleedit'
'subtitleedit.desktop'
'subtitleedit.png')
-sha256sums=('b43b1cb2041810a321bb3e3719d2684a10e515b0e8bbebff9f28d9659eae79ec'
+sha256sums=('39a7ba25f8f50f55e5289c89a040b5a8c392714b2d7954694045022da2bf209e'
'51ae2411ed70a40607a78dd863db98bf5692bfaff7f8c230ddf82f0dc78d1cc3'
'54ffb47864611c6aebb29ecfabd49089cfe6decc320e3f25043c39ec7f27a5fb'
'700d09858ac76341054d7edc79952fbfca70df674d2b567e3713579e5963f631')
-
noextract=("SE${pkgver//./}.zip")
package() {
- install -dm755 "$pkgdir/opt/subtitleedit"
- unzip "$srcdir/SE${pkgver//./}.zip" -d "$pkgdir/opt/subtitleedit"
-
- rm -r "$pkgdir/opt/subtitleedit/Tesseract302"
- rm "$pkgdir/opt/subtitleedit/Hunspell"{x86,x64}.dll
- touch "$pkgdir/opt/subtitleedit/.PACKAGE-MANAGER"
-
- install -Dm755 "$srcdir/subtitleedit" "$pkgdir/usr/bin/subtitleedit"
+ install -dm755 "$pkgdir"/opt/subtitleedit
+ unzip "$srcdir"/SE${pkgver//./}.zip -d "$pkgdir"/opt/subtitleedit
- install -Dm644 "$srcdir/subtitleedit.desktop" "$pkgdir/usr/share/applications/subtitleedit.desktop"
+ rm -r "$pkgdir"/opt/subtitleedit/Tesseract302
+ rm "$pkgdir"/opt/subtitleedit/Hunspell{x86,x64}.dll
+ touch "$pkgdir"/opt/subtitleedit/.PACKAGE-MANAGER
- install -Dm644 "$srcdir/subtitleedit.png" "$pkgdir/usr/share/pixmaps/subtitleedit.png"
+ install -Dm755 "$srcdir"/subtitleedit "$pkgdir"/usr/bin/subtitleedit
+ install -Dm644 "$srcdir"/subtitleedit.desktop "$pkgdir"/usr/share/applications/subtitleedit.desktop
+ install -Dm644 "$srcdir"/subtitleedit.png "$pkgdir"/usr/share/pixmaps/subtitleedit.png
}