summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNocifer2022-03-04 12:45:19 +0200
committerNocifer2022-03-04 12:45:19 +0200
commit86665e3496b90e03f95641c78e125fc717769cf3 (patch)
tree823cb9a3eab6e935e56551053cbcf71b0e15b093
parentf12987e493bc6a7cf73b2c674526d36d57f2dfab (diff)
downloadaur-86665e3496b90e03f95641c78e125fc717769cf3.tar.gz
v=3.6.4,r=2
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD57
-rw-r--r--subtitleedit2
-rw-r--r--subtitleedit.desktop4
-rw-r--r--subtitleedit.pngbin0 -> 30427 bytes
6 files changed, 38 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0873e61f021..d899f40e022c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,23 @@
pkgbase = subtitleedit
- pkgdesc = A subtitle editor
+ pkgdesc = An advanced subtitle editor and converter
pkgver = 3.6.4
- pkgrel = 1
- url = http://www.nikse.dk/subtitleedit/
+ pkgrel = 2
+ url = https://www.nikse.dk/SubtitleEdit
arch = any
license = GPL3
makedepends = unzip
- makedepends = imagemagick
depends = mono
optdepends = vlc: Video support
optdepends = mpv: Video support
optdepends = tesseract: OCR support
noextract = SE364.zip
source = https://github.com/SubtitleEdit/subtitleedit/releases/download/3.6.4/SE364.zip
- source = https://github.com/SubtitleEdit/subtitleedit/raw/3.6.4/src/ui/Icons/SE.ico
source = subtitleedit
source = subtitleedit.desktop
+ source = subtitleedit.png
sha256sums = 9577ac0b570213e7d49acf0cfa8111f843c9ded4a7a962f83ddaf00e345fb843
- sha256sums = 7efc7a341ee949f5b3742741a1431c0af7ab14aa1d7f35a654f6ec2eb4fc9457
- sha256sums = 2060b2b85e2c50152a266a3697efe7b9fbfe7c2af4cdf6a9c6af8a30a6169b52
- sha256sums = 32977a0b82619f04e1ce904ac9c02ced410aa6cb563e86e90ce46225dc63adee
+ sha256sums = 51ae2411ed70a40607a78dd863db98bf5692bfaff7f8c230ddf82f0dc78d1cc3
+ sha256sums = 54ffb47864611c6aebb29ecfabd49089cfe6decc320e3f25043c39ec7f27a5fb
+ sha256sums = 700d09858ac76341054d7edc79952fbfca70df674d2b567e3713579e5963f631
pkgname = subtitleedit
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index f65adfadc146..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,6 +0,0 @@
-/*.tar.xz
-/*.tar.zst
-/*.zip
-/*.ico
-/pkg
-/src
diff --git a/PKGBUILD b/PKGBUILD
index e205e18d0373..fe6bf170dbdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,40 @@
+# Maintainer: Nocifer <apmichalopoulos at gmail dot com>
+# Contributor: eduardosm
+
pkgname=subtitleedit
pkgver=3.6.4
-pkgrel=1
-pkgdesc="A subtitle editor"
+pkgrel=2
+pkgdesc='An advanced subtitle editor and converter'
arch=('any')
-url="http://www.nikse.dk/subtitleedit/"
+url='https://www.nikse.dk/SubtitleEdit'
license=('GPL3')
depends=('mono')
-optdepends=(
- 'vlc: Video support'
- 'mpv: Video support'
- 'tesseract: OCR support'
-)
-makedepends=('unzip' 'imagemagick')
-source=(
- "https://github.com/SubtitleEdit/subtitleedit/releases/download/$pkgver/SE${pkgver//./}.zip"
- "https://github.com/SubtitleEdit/subtitleedit/raw/$pkgver/src/ui/Icons/SE.ico"
- "subtitleedit"
- "subtitleedit.desktop"
-)
-sha256sums=(
- '9577ac0b570213e7d49acf0cfa8111f843c9ded4a7a962f83ddaf00e345fb843'
- '7efc7a341ee949f5b3742741a1431c0af7ab14aa1d7f35a654f6ec2eb4fc9457'
- '2060b2b85e2c50152a266a3697efe7b9fbfe7c2af4cdf6a9c6af8a30a6169b52'
- '32977a0b82619f04e1ce904ac9c02ced410aa6cb563e86e90ce46225dc63adee'
-)
+optdepends=('vlc: Video support'
+ 'mpv: Video support'
+ 'tesseract: OCR support')
+makedepends=('unzip')
+source=("https://github.com/SubtitleEdit/subtitleedit/releases/download/$pkgver/SE${pkgver//./}.zip"
+ 'subtitleedit'
+ 'subtitleedit.desktop'
+ 'subtitleedit.png')
+sha256sums=('9577ac0b570213e7d49acf0cfa8111f843c9ded4a7a962f83ddaf00e345fb843'
+ '51ae2411ed70a40607a78dd863db98bf5692bfaff7f8c230ddf82f0dc78d1cc3'
+ '54ffb47864611c6aebb29ecfabd49089cfe6decc320e3f25043c39ec7f27a5fb'
+ '700d09858ac76341054d7edc79952fbfca70df674d2b567e3713579e5963f631')
+
noextract=("SE${pkgver//./}.zip")
package() {
- install -d "$pkgdir/usr/share/subtitleedit"
- unzip "$srcdir/SE${pkgver//./}.zip" -d "$pkgdir/usr/share/subtitleedit"
- rm -r "$pkgdir/usr/share/subtitleedit/Tesseract302"
- rm "$pkgdir/usr/share/subtitleedit/Hunspell"{x86,x64}.dll
- touch "$pkgdir/usr/share/subtitleedit/.PACKAGE-MANAGER"
+ install -dm755 "$pkgdir/opt/subtitleedit"
+ unzip "$srcdir/SE${pkgver//./}.zip" -d "$pkgdir/opt/subtitleedit"
+
+ rm -r "$pkgdir/opt/subtitleedit/Tesseract302"
+ rm "$pkgdir/opt/subtitleedit/Hunspell"{x86,x64}.dll
+ touch "$pkgdir/opt/subtitleedit/.PACKAGE-MANAGER"
+
+ install -Dm644 "$srcdir/subtitleedit" "$pkgdir/usr/bin/subtitleedit"
- install -Dm755 "$srcdir/subtitleedit" "$pkgdir/usr/bin/subtitleedit"
install -Dm644 "$srcdir/subtitleedit.desktop" "$pkgdir/usr/share/applications/subtitleedit.desktop"
- install -d "$pkgdir/usr/share/pixmaps"
- convert "$srcdir/SE.ico[9]" "$pkgdir/usr/share/pixmaps/subtitleedit.png"
+ install -Dm644 "$srcdir/subtitleedit.png" "$pkgdir/usr/share/pixmaps/subtitleedit.png"
}
diff --git a/subtitleedit b/subtitleedit
index 226c90d1ca1d..d46545c899b6 100644
--- a/subtitleedit
+++ b/subtitleedit
@@ -1,2 +1,2 @@
#!/bin/sh
-exec mono /usr/share/subtitleedit/SubtitleEdit.exe "$@"
+exec mono /opt/subtitleedit/SubtitleEdit.exe "$@"
diff --git a/subtitleedit.desktop b/subtitleedit.desktop
index 068bd17367ca..b7459a419f4f 100644
--- a/subtitleedit.desktop
+++ b/subtitleedit.desktop
@@ -1,8 +1,8 @@
[Desktop Entry]
Name=Subtitle Edit
-Comment=A subtitle editor
+Comment=An advanced subtitle editor and converter
Exec=/usr/bin/subtitleedit %F
-Icon=/usr/share/pixmaps/subtitleedit.png
+Icon=subtitleedit
Terminal=false
Type=Application
Categories=Video;AudioVideo;AudioVideoEditing;
diff --git a/subtitleedit.png b/subtitleedit.png
new file mode 100644
index 000000000000..659dbf709e84
--- /dev/null
+++ b/subtitleedit.png
Binary files differ