summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Sánchez Muñoz2016-08-06 23:58:40 +0200
committerEduardo Sánchez Muñoz2016-08-06 23:58:40 +0200
commitb9d43f167e829c8428fdde507a2b39fa12d5c47d (patch)
tree3e7df178bc7420743e255cc5973ea67d5b9c8ea2
parent10ec2967ef453b4e3eb135a1a4f0e5fd7dc26343 (diff)
downloadaur-b9d43f167e829c8428fdde507a2b39fa12d5c47d.tar.gz
Apply larvan's suggestions.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rw-r--r--subtitleedit2
3 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c0c10234dd7..a3f7eb82bd71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Jul 9 10:55:28 UTC 2016
+# Sat Aug 6 21:56:54 UTC 2016
pkgbase = subtitleedit
pkgdesc = A subtitle editor
pkgver = 3.4.13
- pkgrel = 1
+ pkgrel = 2
url = http://www.nikse.dk/subtitleedit/
arch = i686
arch = x86_64
@@ -11,6 +11,7 @@ pkgbase = subtitleedit
makedepends = unzip
makedepends = imagemagick
depends = mono
+ optdepends = vlc: Video support
noextract = SE3413.zip
source = https://github.com/SubtitleEdit/subtitleedit/releases/download/3.4.13/SE3413.zip
source = https://raw.githubusercontent.com/SubtitleEdit/subtitleedit/3.4.13/src/Icons/SE.ico
@@ -18,7 +19,7 @@ pkgbase = subtitleedit
source = subtitleedit.desktop
sha256sums = f2d412fe04ae1fc1df0bb19ae67522a6ac270be3e3831933852ec3380e68c674
sha256sums = a2d211e7ce3597b25db9f921590169c89d0b47dad48669dfffb6795a7ba534cd
- sha256sums = 2b3a8541cfd6fffc081e4b0163c226f2b3eefdc8729035098113a0c9792f25ae
+ sha256sums = f1e7b1ef8116afaaac61a6ddd871fb6ec349ab729d068f1c3195d0fbabafc2bc
sha256sums = 5423868ec98b14cf2f46fe07f48f69477ad45409be90d1e8e58aaa2d1120faa1
pkgname = subtitleedit
diff --git a/PKGBUILD b/PKGBUILD
index 4e66db5474bb..e69c0b5c09fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
pkgname=subtitleedit
pkgver=3.4.13
-pkgrel=1
+pkgrel=2
pkgdesc="A subtitle editor"
arch=('i686' 'x86_64')
url="http://www.nikse.dk/subtitleedit/"
license=('GPL3')
depends=('mono')
+optdepends=('vlc: Video support')
makedepends=('unzip' 'imagemagick')
source=(
"https://github.com/SubtitleEdit/subtitleedit/releases/download/$pkgver/SE${pkgver//./}.zip"
@@ -16,7 +17,7 @@ source=(
sha256sums=(
'f2d412fe04ae1fc1df0bb19ae67522a6ac270be3e3831933852ec3380e68c674'
'a2d211e7ce3597b25db9f921590169c89d0b47dad48669dfffb6795a7ba534cd'
- '2b3a8541cfd6fffc081e4b0163c226f2b3eefdc8729035098113a0c9792f25ae'
+ 'f1e7b1ef8116afaaac61a6ddd871fb6ec349ab729d068f1c3195d0fbabafc2bc'
'5423868ec98b14cf2f46fe07f48f69477ad45409be90d1e8e58aaa2d1120faa1'
)
noextract=("SE${pkgver//./}.zip")
@@ -24,6 +25,7 @@ noextract=("SE${pkgver//./}.zip")
package() {
install -d "$pkgdir/usr/share/subtitleedit"
unzip "$srcdir/SE${pkgver//./}.zip" -d "$pkgdir/usr/share/subtitleedit"
+ touch "$pkgdir/usr/share/subtitleedit/.PACKAGE-MANAGER"
install -Dm755 "$srcdir/subtitleedit" "$pkgdir/usr/bin/subtitleedit"
install -Dm644 "$srcdir/subtitleedit.desktop" "$pkgdir/usr/share/applications/subtitleedit.desktop"
diff --git a/subtitleedit b/subtitleedit
index 1ee3453e23f5..e15a26bd1e1c 100644
--- a/subtitleedit
+++ b/subtitleedit
@@ -1,2 +1,2 @@
#!/bin/sh
-mono /usr/share/subtitleedit/SubtitleEdit.exe
+mono /usr/share/subtitleedit/SubtitleEdit.exe "$@"