summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-19 15:25:10 +0800
committerzxp198210052024-01-19 15:25:10 +0800
commitd6a0fa1acbe4a74140a5c71127be921aa9390182 (patch)
treee923c161b838463732dee1704ccf340e754cb0eb
parent9b6f8f55149571924103d7fc8deb92dc797c6094 (diff)
downloadaur-d6a0fa1acbe4a74140a5c71127be921aa9390182.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--subtitler.sh13
3 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d2bb9e7d216..9db1cd233e9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = subtitler-bin
pkgdesc = Quickly download subtitles
pkgver = 1.5.5
- pkgrel = 6
+ pkgrel = 7
url = https://s8sachin.github.io/subtitler/
arch = x86_64
license = MIT
@@ -14,6 +14,6 @@ pkgbase = subtitler-bin
source = subtitler.sh
sha256sums = ca37a8487fcf6283b36adcb43de9ebc4a12d7bd2ab96a73a1695f3c2b4d51f81
sha256sums = 61c4ef762e75d209db99b0ddd77c9931c1d966f19d72b5dc1f46e8041f18309c
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
pkgname = subtitler-bin
diff --git a/PKGBUILD b/PKGBUILD
index ac8f06ebb85e..bc2da3eafcbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=subtitler-bin
_pkgname=Subtitler
pkgver=1.5.5
_electronversion=8
-pkgrel=6
+pkgrel=7
pkgdesc="Quickly download subtitles"
arch=("x86_64")
url="https://s8sachin.github.io/subtitler/"
@@ -22,14 +22,14 @@ source=(
)
sha256sums=('ca37a8487fcf6283b36adcb43de9ebc4a12d7bd2ab96a73a1695f3c2b4d51f81'
'61c4ef762e75d209db99b0ddd77c9931c1d966f19d72b5dc1f46e8041f18309c'
- '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@appasar@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
- sed "s|/opt/${_pkgname}/${pkgname%-bin} %U|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/subtitler.sh b/subtitler.sh
index 2ec4412e5c4f..aacd8f895847 100644
--- a/subtitler.sh
+++ b/subtitler.sh
@@ -1,14 +1,15 @@
-#!/bin/bash
+#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file