summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2015-08-08 17:08:56 +0200
committerBenjamin Chrétien2015-08-08 17:08:56 +0200
commit31ff0d2cd4c12ba49283749beb225e8149aa7ed3 (patch)
tree7ca2ade19d0c643d8c4512ae4e610b20928d47f5
downloadaur-31ff0d2cd4c12ba49283749beb225e8149aa7ed3.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51ddad32e433
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = subuser
+ pkgdesc = Run programs in linux with selectively restricted permissions
+ pkgver = 0.3
+ pkgrel = 1
+ url = http://subuser.org
+ arch = any
+ license = LGPL3
+ makedepends = python
+ depends = python
+ depends = docker
+ source = https://github.com/subuser-security/subuser/archive/0.3.tar.gz
+ sha256sums = c811e5c7161eb4b35bfb57c5f79b3487e9ee92b75775012101fd7c36bef8a27d
+
+pkgname = subuser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d6eb2ce8ec6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=subuser
+_name=subuser
+pkgver=0.3
+pkgrel=1
+pkgdesc="Run programs in linux with selectively restricted permissions"
+url="http://subuser.org"
+depends=('python' 'docker')
+makedepends=('python')
+optdepends=()
+license=('LGPL3')
+arch=('any')
+source=("https://github.com/subuser-security/${_name}/archive/${pkgver}.tar.gz")
+sha256sums=('c811e5c7161eb4b35bfb57c5f79b3487e9ee92b75775012101fd7c36bef8a27d')
+
+package() {
+ cd "$srcdir/${_name}-${pkgver}"
+
+ # For now, nothing is built, the source directory is expected to be copied
+ # somewhere (see http://subuser.org/installation.html#installation).
+ # /opt/subuser is currently used, but this is likely to change.
+
+ install -d "$pkgdir/usr/bin"
+ ln -s "/opt/subuser/logic/subuser" "$pkgdir/usr/bin/subuser"
+
+ install -d -m 755 "$pkgdir/opt/subuser"
+ install -D -m 644 *.json "$pkgdir/opt/subuser"
+
+ # TODO: check permissions
+ cp -dr --no-preserve='ownership' {logic,test} "$pkgdir/opt/subuser/"
+ chmod -R 755 "$pkgdir/opt/subuser/"{logic,test}
+
+ chmod +x "$pkgdir/opt/subuser/logic/subuser"
+}