summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2016-02-13 13:07:04 +0900
committerBenjamin Chrétien2016-02-13 13:07:04 +0900
commit51d628ec998ddc32317dd0be5d80227dec835328 (patch)
tree29bfab4b8035e820ab944383f81c0a1ce893d931
parentfc62e2ced9fcb758d7c3443f5e3e1dbb57ed2f8e (diff)
downloadaur-51d628ec998ddc32317dd0be5d80227dec835328.tar.gz
Update to version 0.5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 13 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fcb8422837e..6b1c35a48187 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sat Feb 13 04:06:49 UTC 2016
pkgbase = subuser
pkgdesc = Run programs in linux with selectively restricted permissions
- pkgver = 0.4
+ pkgver = 0.5
pkgrel = 1
url = http://subuser.org
arch = any
@@ -8,8 +10,8 @@ pkgbase = subuser
makedepends = python
depends = python
depends = docker
- source = https://github.com/subuser-security/subuser/archive/0.4.tar.gz
- sha256sums = 2b53a0be7f01dacc5a09d9e3f592578a38922e3a2f103142077fd05fa09cbafd
+ source = https://github.com/subuser-security/subuser/archive/0.5.tar.gz
+ sha256sums = 8fd4ccd8aff7c6ba760411346f655e2fd9a5a2ab75c924785449059bea1cbf36
pkgname = subuser
diff --git a/PKGBUILD b/PKGBUILD
index c31a4d491fe3..eafbec5a12da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=subuser
_name=subuser
-pkgver=0.4
+pkgver=0.5
pkgrel=1
pkgdesc="Run programs in linux with selectively restricted permissions"
url="http://subuser.org"
@@ -10,24 +10,14 @@ optdepends=()
license=('LGPL3')
arch=('any')
source=("https://github.com/subuser-security/${_name}/archive/${pkgver}.tar.gz")
-sha256sums=('2b53a0be7f01dacc5a09d9e3f592578a38922e3a2f103142077fd05fa09cbafd')
+sha256sums=('8fd4ccd8aff7c6ba760411346f655e2fd9a5a2ab75c924785449059bea1cbf36')
-package() {
+build() {
cd "$srcdir/${_name}-${pkgver}"
+ python setup.py build
+}
- # For now, nothing is built, the source directory is expected to be copied
- # somewhere (see http://subuser.org/installation.html#installation).
- # /opt/subuser is currently used, but this is likely to change.
-
- install -d "$pkgdir/usr/bin"
- ln -s "/opt/subuser/logic/subuser" "$pkgdir/usr/bin/subuser"
-
- install -d -m 755 "$pkgdir/opt/subuser"
- install -D -m 644 *.json "$pkgdir/opt/subuser"
-
- # TODO: check permissions
- cp -dr --no-preserve='ownership' {logic,test} "$pkgdir/opt/subuser/"
- chmod -R 755 "$pkgdir/opt/subuser/"{logic,test}
-
- chmod +x "$pkgdir/opt/subuser/logic/subuser"
+package() {
+ cd "$srcdir/${_name}-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1
}