summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Arnott2017-12-10 09:20:33 +0000
committerColin Arnott2017-12-10 09:20:33 +0000
commit545a15bd6e6ffa33d66359700f481d81be4cd560 (patch)
treea6a14d89e0cbd782da908bb25be1b10d7e0f6bb5
downloadaur-545a15bd6e6ffa33d66359700f481d81be4cd560.tar.gz
init: v0.8.1
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa6611684b8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Sun Dec 10 09:19:24 UTC 2017
+pkgbase = sucks
+ pkgdesc = Simple command-line script for the Ecovacs series of robot vacuums
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = https://github.com/wpietri/sucks
+ arch = any
+ license = GPL
+ checkdepends = python-nose
+ checkdepends = python-requests-mock
+ depends = python
+ depends = python-sleekxmpp
+ depends = python-click
+ depends = python-requests
+ depends = python-pycryptodome
+ depends = python-pycountry-convert
+ source = https://github.com/wpietri/sucks/archive/v0.8.1.tar.gz
+ sha512sums = 45b64b65a9fe012cb8f59757ce6ae5e94822f4621c0f165e0782007d8fc8be6974d3aa6a5f5feee0cf8dbb2ca08a5e79315ae933791004fa90ce5bd228c797b7
+
+pkgname = sucks
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43caf5278fa0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Colin Arnott <colin@urandom.co.uk>
+
+pkgname=sucks
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="Simple command-line script for the Ecovacs series of robot vacuums"
+arch=(any)
+url="https://github.com/wpietri/sucks"
+license=('GPL')
+depends=('python' 'python-sleekxmpp' 'python-click' 'python-requests' 'python-pycryptodome' 'python-pycountry-convert')
+checkdepends=('python-nose' 'python-requests-mock')
+backup=()
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha512sums=('45b64b65a9fe012cb8f59757ce6ae5e94822f4621c0f165e0782007d8fc8be6974d3aa6a5f5feee0cf8dbb2ca08a5e79315ae933791004fa90ce5bd228c797b7')
+
+check() {
+ cd "$pkgname-$pkgver"
+ nosetests
+}
+
+package() {
+ install -Dm755 $pkgname-$pkgver/sucks.py $pkgdir/usr/bin/sucks
+ sed -i '1i #!/usr/bin/python' $pkgdir/usr/bin/sucks
+}