summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Arnott2017-12-10 11:16:38 +0000
committerColin Arnott2017-12-10 11:16:38 +0000
commit7eb53a78ebdd852b96b64c1ec27ecaa9a9386b56 (patch)
tree5ddff42ce41ca9c98292833c600acd9d44699fee
parent545a15bd6e6ffa33d66359700f481d81be4cd560 (diff)
downloadaur-7eb53a78ebdd852b96b64c1ec27ecaa9a9386b56.tar.gz
add bash completion
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa6611684b8e..bf24422634f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Dec 10 09:19:24 UTC 2017
+# Sun Dec 10 11:16:32 UTC 2017
pkgbase = sucks
pkgdesc = Simple command-line script for the Ecovacs series of robot vacuums
pkgver = 0.8.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/wpietri/sucks
arch = any
license = GPL
@@ -15,6 +15,7 @@ pkgbase = sucks
depends = python-requests
depends = python-pycryptodome
depends = python-pycountry-convert
+ optdepends = bash-completion
source = https://github.com/wpietri/sucks/archive/v0.8.1.tar.gz
sha512sums = 45b64b65a9fe012cb8f59757ce6ae5e94822f4621c0f165e0782007d8fc8be6974d3aa6a5f5feee0cf8dbb2ca08a5e79315ae933791004fa90ce5bd228c797b7
diff --git a/PKGBUILD b/PKGBUILD
index 43caf5278fa0..9acd80e656ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
pkgname=sucks
pkgver=0.8.1
-pkgrel=1
+pkgrel=2
pkgdesc="Simple command-line script for the Ecovacs series of robot vacuums"
arch=(any)
url="https://github.com/wpietri/sucks"
license=('GPL')
depends=('python' 'python-sleekxmpp' 'python-click' 'python-requests' 'python-pycryptodome' 'python-pycountry-convert')
checkdepends=('python-nose' 'python-requests-mock')
+optdepends=('bash-completion')
backup=()
source=("${url}/archive/v${pkgver}.tar.gz")
sha512sums=('45b64b65a9fe012cb8f59757ce6ae5e94822f4621c0f165e0782007d8fc8be6974d3aa6a5f5feee0cf8dbb2ca08a5e79315ae933791004fa90ce5bd228c797b7')
@@ -21,4 +22,5 @@ check() {
package() {
install -Dm755 $pkgname-$pkgver/sucks.py $pkgdir/usr/bin/sucks
sed -i '1i #!/usr/bin/python' $pkgdir/usr/bin/sucks
+ _SUCKS_COMPLETE=source sucks | install -Dm644 /dev/stdin $pkgdir/usr/share/bash-completion/completions/sucks
}