summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris2016-07-11 19:08:56 +0100
committerChris2016-07-11 19:08:56 +0100
commitc0cb5aeb99e6800270e61c4115e5dda06cfc602d (patch)
tree39b38e25774feb8eb23947ed362e988eda4b68ff
downloadaur-c0cb5aeb99e6800270e61c4115e5dda06cfc602d.tar.gz
initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD76
-rw-r--r--sudo-masochist.install26
-rw-r--r--sudo.pam4
4 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d03c5e4be0dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = sudo-masochist
+ pkgdesc = Sudo with a little extra edge
+ pkgver = 1.8.17.p1
+ pkgrel = 1
+ url = https://www.sudo.ws/sudo/
+ install = sudo-masochist.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = glibc
+ depends = pam
+ depends = libldap
+ provides = sudo
+ conflicts = sudo
+ backup = etc/sudoers
+ backup = etc/pam.d/sudo
+ source = https://www.sudo.ws/sudo/dist/sudo-1.8.17p1.tar.gz
+ source = https://www.sudo.ws/sudo/dist/sudo-1.8.17p1.tar.gz.sig
+ source = sudo.pam
+ source = git+http://bitbucket.org/NextHendrix/sudo-masochist
+ validpgpkeys = CCB24BE9E9481B15D34159535A89DFA27EE470C4
+ sha256sums = c690d707fb561b3ecdf6a6de5563bc0b769388eff201c851edbace408bb155cc
+ sha256sums = SKIP
+ sha256sums = d1738818070684a5d2c9b26224906aad69a4fea77aabd960fc2675aee2df1fa2
+ sha256sums = SKIP
+
+pkgname = sudo-masochist
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4558dc628945
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# sudo with insult gains
+# safe-space disabled permanently
+# not for the easily offended
+#
+# NB: This package does not edit the functionality of sudo in any way apart
+# from adding extra insults for obvious reasons, and tracks sudo
+# directly from upstream.
+#
+# Maintainer: NextHendrix <cjones12@sheffield.ac.uk>
+
+
+pkgname=sudo-masochist
+_sudover=1.8.17p1
+pkgver=${_sudover/p/.p}
+pkgrel=1
+pkgdesc="Sudo with a little extra edge"
+arch=('i686' 'x86_64')
+url="https://www.sudo.ws/sudo/"
+license=('custom')
+depends=('glibc' 'pam' 'libldap')
+backup=('etc/sudoers' 'etc/pam.d/sudo')
+install=$pkgname.install
+provides=('sudo')
+conflicts=('sudo')
+source=(https://www.sudo.ws/sudo/dist/sudo-$_sudover.tar.gz{,.sig}
+ sudo.pam
+ git+http://bitbucket.org/NextHendrix/sudo-masochist)
+
+sha256sums=('c690d707fb561b3ecdf6a6de5563bc0b769388eff201c851edbace408bb155cc'
+ 'SKIP'
+ 'd1738818070684a5d2c9b26224906aad69a4fea77aabd960fc2675aee2df1fa2'
+ 'SKIP')
+validpgpkeys=('CCB24BE9E9481B15D34159535A89DFA27EE470C4')
+
+build() {
+ cd "$srcdir/sudo-masochist"
+ cp insults/* "$srcdir/sudo-$_sudover/plugins/sudoers/" -f
+ cd "$srcdir/sudo-$_sudover"
+
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib \
+ --with-rundir=/run/sudo \
+ --with-vardir=/var/db/sudo \
+ --with-logfac=auth \
+ --enable-tmpfiles.d \
+ --with-pam \
+ --with-sssd \
+ --with-ldap \
+ --with-ldap-conf-file=/etc/openldap/ldap.conf \
+ --with-env-editor \
+ --with-passprompt="[sudo] password for %p: " \
+ --with-all-insults
+ make
+}
+
+check() {
+ cd "$srcdir/sudo-$_sudover"
+ make check
+}
+
+package() {
+ cd "$srcdir/sudo-$_sudover"
+ make DESTDIR="$pkgdir" install
+
+ # Remove /run/sudo directory from the package; we create it using tmpfiles.d
+ rmdir "$pkgdir/run/sudo"
+ rmdir "$pkgdir/run"
+
+ install -Dm644 "$srcdir/sudo.pam" "$pkgdir/etc/pam.d/sudo"
+
+ install -Dm644 doc/LICENSE "$pkgdir/usr/share/licenses/sudo/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/sudo-masochist.install b/sudo-masochist.install
new file mode 100644
index 000000000000..ef941ed7aa9e
--- /dev/null
+++ b/sudo-masochist.install
@@ -0,0 +1,26 @@
+post_install() {
+ if type -P systemd-tmpfiles >/dev/null; then
+ systemd-tmpfiles --create sudo.conf
+ fi
+ printf "#####################################################################################\n"
+ printf "# I hope you weren't dumb enough to disable the root password! #\n"
+ printf "# Your old config is stored at /etc/sudoers.pacsave should you want to restore it. #\n"
+ printf "# Don't forget to add 'Defaults !lecture,tty_tickets,insults' to your sudoers file. #\n"
+ printf "# Type your sudo password wrong and it will make you cry. #\n"
+ printf "# Also, reinstall every now and again im adding insults all the time. #\n"
+ printf "#####################################################################################\n"
+}
+
+pre_upgrade() {
+ # Permissions of /var/db/sudo were changed from 0700 to 0711 in sudo 1.8.10
+ # http://www.sudo.ws/repos/sudo/rev/5c38d77a2d0c
+ if (($(vercmp $2 1.8.10-1) < 0)); then
+ chmod 0711 var/db/sudo
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/sudo.pam b/sudo.pam
new file mode 100644
index 000000000000..ab053c543002
--- /dev/null
+++ b/sudo.pam
@@ -0,0 +1,4 @@
+#%PAM-1.0
+auth include system-auth
+account include system-auth
+session include system-auth