summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2023-09-02 10:07:26 +0800
committertaotieren2023-09-02 10:07:26 +0800
commitd1e4d5f46898ca61b7e1b14ad83fc4bb3af74f15 (patch)
treeeda12d65bc62878e99ebb512890a4d4923689ea6
parentd60df317a654fdf2ba6e9a68a8bb29af39c42895 (diff)
downloadaur-d1e4d5f46898ca61b7e1b14ad83fc4bb3af74f15.tar.gz
Update 0.2.0-3
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--sudo-rs.install12
3 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a40bb466112c..eaea42f12195 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = sudo-rs
- pkgdesc = A memory safe implementation of sudo and su.
+ pkgdesc = A safety oriented and memory safe implementation of sudo and su written in Rust.
pkgver = 0.2.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/memorysafety/sudo-rs
+ install = sudo-rs.install
arch = any
license = Apache 2.0,
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 236505a6fae4..1889c29f5651 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=sudo-rs
pkgver=0.2.0
-pkgrel=2
-pkgdesc="A memory safe implementation of sudo and su."
+pkgrel=3
+pkgdesc="A safety oriented and memory safe implementation of sudo and su written in Rust."
arch=('any')
url="https://github.com/memorysafety/sudo-rs"
license=('Apache 2.0', 'MIT')
@@ -16,7 +16,7 @@ makedepends=(cargo
pam)
backup=()
options=('!strip')
-#install=${pkgname}.install
+install=${pkgname}.install
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
sha256sums=('2d1e6bdfc8f14a6023328ffd48a00f7c973409e7bdc6199f484c095ad9817090')
diff --git a/sudo-rs.install b/sudo-rs.install
new file mode 100644
index 000000000000..8bcdd59bcc42
--- /dev/null
+++ b/sudo-rs.install
@@ -0,0 +1,12 @@
+info() {
+ echo -e "Sudo-rs is currently under active development and is not suited for any production environment. Using sudo-rs is only recommended for development and testing purposes, but you should expect any system that has sudo-rs installed to break easily and to not be secure."
+ echo -e "Sudo-rs issue tracker: https://github.com/memorysafety/sudo-rs/issues"
+ echo -e "Sudo-rs security page: https://github.com/memorysafety/sudo-rs/security"
+}
+post_install() {
+ info
+}
+post_upgrade() {
+ info
+}
+