summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranon2023-05-04 22:25:24 +0200
committeranon2023-05-04 22:25:24 +0200
commit1dfb1f607e5ae4f9db71d772a875e603981c2232 (patch)
tree0e01d60e1074fe1d60fb36639a6a5ac269475330
parent09978ff274d39b1d2d8ef55645e15c123c338e26 (diff)
downloadaur-1dfb1f607e5ae4f9db71d772a875e603981c2232.tar.gz
Update, fix license installation issue
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1ee0c3fd7b3..cd192d144246 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sudo-rs-git
pkgdesc = A memory safe implementation of sudo and su.
- pkgver = 2023.04.30.fe8bf15
+ pkgver = 2023.05.04.da23204
pkgrel = 1
url = https://github.com/memorysafety/sudo-rs
install = warning.install
@@ -8,7 +8,7 @@ pkgbase = sudo-rs-git
license = Apache 2.0,
license = MIT
provides = sudo-rs
- source = source.zip::https://github.com/memorysafety/sudo-rs/archive/fe8bf15a238cc48c4518fe9d5ec593fdef89d863.zip
- sha512sums = 3d4df0749079f53e43af9b654e9d200aff8ea2d9e00d86cdd17ce2537201a5ced27799a51e17174fa3445e6738f8c7856d0b303ad2ecfd27188d18a17fd04a7b
+ source = source.zip::https://github.com/memorysafety/sudo-rs/archive/da232041958a06dee67f70dafff6e21302de683f.zip
+ sha512sums = b9fd2806b977986b8350ad16c91a3ffb1e6d887aaa0e878e88ce4fa8e8d20081c7d4a406d893f86cb70399a462d5c705d280ba7fc9859fe0f2e518a8135c4c1d
pkgname = sudo-rs-git
diff --git a/PKGBUILD b/PKGBUILD
index 002cb035bbf4..54d98adc7dd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Anarcoco <archlinux.dn4qx@slmail.me>
pkgname=sudo-rs-git
-pkgver=2023.04.30.fe8bf15
+pkgver=2023.05.04.da23204
pkgrel=1
pkgdesc="A memory safe implementation of sudo and su. "
arch=('any')
@@ -8,10 +8,10 @@ url="https://github.com/memorysafety/sudo-rs"
license=('Apache 2.0', 'MIT')
builddepends=('rust', 'cargo', 'clang')
provides=(sudo-rs) # Will replace with "sudo" when sudo-rs becomes stable.
-_commit=fe8bf15a238cc48c4518fe9d5ec593fdef89d863
+_commit=da232041958a06dee67f70dafff6e21302de683f
source=("source.zip"::"https://github.com/memorysafety/sudo-rs/archive/$_commit.zip")
install=warning.install
-sha512sums=('3d4df0749079f53e43af9b654e9d200aff8ea2d9e00d86cdd17ce2537201a5ced27799a51e17174fa3445e6738f8c7856d0b303ad2ecfd27188d18a17fd04a7b') # Generated by me.
+sha512sums=('b9fd2806b977986b8350ad16c91a3ffb1e6d887aaa0e878e88ce4fa8e8d20081c7d4a406d893f86cb70399a462d5c705d280ba7fc9859fe0f2e518a8135c4c1d') # Generated by me.
build() {
cd $srcdir/sudo-rs-$_commit
cargo build --release
@@ -19,6 +19,6 @@ build() {
package() {
cd $srcdir/sudo-rs-$_commit
install -Dm644 LICENSE-MIT "$pkgdir/usr/share/licenses/sudo-rs/LICENSE-MIT"
- install -Dm644 LICENSE-MIT "$pkgdir/usr/share/licenses/sudo-rs/LICENSE-MIT"
+ install -Dm644 LICENSE-APACHE "$pkgdir/usr/share/licenses/sudo-rs/LICENSE-APACHE"
install -Dm4755 target/release/sudo "$pkgdir/usr/bin/sudo-rs" # Will replace with "sudo" when sudo-rs becomes stable.
}