summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2018-08-29 12:32:25 +0200
committerNicolas Iooss2018-08-29 12:32:25 +0200
commit11c3d723e2ac2d481d4ad4051de38bf1f8f2c639 (patch)
tree1312a9ffd0c7d5bd3edc869d8d295b2a0e0596c8
parenta657b5e2cf5d4e7e8e1e68715975d078c299006a (diff)
downloadaur-11c3d723e2ac2d481d4ad4051de38bf1f8f2c639.tar.gz
sudo-selinux 1.8.24-1 update
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD11
-rw-r--r--allow-preserve-env-with-arg.patch35
3 files changed, 10 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f53c2aa988fb..bdde1ab93a79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sudo-selinux
pkgdesc = Give certain users the ability to run some commands as root - SELinux support
- pkgver = 1.8.23
- pkgrel = 2
+ pkgver = 1.8.24
+ pkgrel = 1
url = https://www.sudo.ws/sudo/
install = sudo.install
arch = x86_64
@@ -12,20 +12,18 @@ pkgbase = sudo-selinux
depends = pam-selinux
depends = libldap
depends = libselinux
- provides = sudo=1.8.23-2
- provides = selinux-sudo=1.8.23-2
+ provides = sudo=1.8.24-1
+ provides = selinux-sudo=1.8.24-1
conflicts = sudo
conflicts = selinux-sudo
backup = etc/sudoers
backup = etc/pam.d/sudo
- source = https://www.sudo.ws/sudo/dist/sudo-1.8.23.tar.gz
- source = https://www.sudo.ws/sudo/dist/sudo-1.8.23.tar.gz.sig
- source = allow-preserve-env-with-arg.patch
+ source = https://www.sudo.ws/sudo/dist/sudo-1.8.24.tar.gz
+ source = https://www.sudo.ws/sudo/dist/sudo-1.8.24.tar.gz.sig
source = sudo.pam
validpgpkeys = 59D1E9CCBA2B376704FDD35BA9F4C021CEA470FB
- sha256sums = d863d29b6fc87bc784a3223350e2b28a2ff2c4738f0fb8f1c92bb38c3017e679
+ sha256sums = b488557a198ecef30b7ad4011b59a66232dec2364ad956e11d8e17906c225be8
sha256sums = SKIP
- sha256sums = 439edd65dbc0115794dec833968c538c98a275522ec9a2e0ac3d4a9eb9cc3b33
sha256sums = d1738818070684a5d2c9b26224906aad69a4fea77aabd960fc2675aee2df1fa2
pkgname = sudo-selinux
diff --git a/PKGBUILD b/PKGBUILD
index e5431f60bcde..78ea3e47759e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,9 +10,9 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=sudo-selinux
-_sudover=1.8.23
+_sudover=1.8.24
pkgver=${_sudover/p/.p}
-pkgrel=2
+pkgrel=1
pkgdesc="Give certain users the ability to run some commands as root - SELinux support"
arch=('x86_64')
url="https://www.sudo.ws/sudo/"
@@ -25,19 +25,14 @@ provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}"
backup=('etc/sudoers' 'etc/pam.d/sudo')
install=${pkgname/-selinux}.install
source=(https://www.sudo.ws/sudo/dist/${pkgname/-selinux}-$_sudover.tar.gz{,.sig}
- allow-preserve-env-with-arg.patch
sudo.pam)
-sha256sums=('d863d29b6fc87bc784a3223350e2b28a2ff2c4738f0fb8f1c92bb38c3017e679'
+sha256sums=('b488557a198ecef30b7ad4011b59a66232dec2364ad956e11d8e17906c225be8'
'SKIP'
- '439edd65dbc0115794dec833968c538c98a275522ec9a2e0ac3d4a9eb9cc3b33'
'd1738818070684a5d2c9b26224906aad69a4fea77aabd960fc2675aee2df1fa2')
validpgpkeys=('59D1E9CCBA2B376704FDD35BA9F4C021CEA470FB')
prepare() {
cd "$srcdir/${pkgname/-selinux}-$_sudover"
-
- # https://bugzilla.sudo.ws/show_bug.cgi?id=835
- patch -Np1 -i ../allow-preserve-env-with-arg.patch
}
build() {
diff --git a/allow-preserve-env-with-arg.patch b/allow-preserve-env-with-arg.patch
deleted file mode 100644
index 8bf6acc1be47..000000000000
--- a/allow-preserve-env-with-arg.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-
-# HG changeset patch
-# User Todd C. Miller <Todd.Miller@sudo.ws>
-# Date 1526483443 21600
-# Node ID 8ea75ca8fbd2de3877fed1b83a63d9ac8a9c14b1
-# Parent 7972215392428f23eb47c11ddffc0cc8a824fff0
-Only set MODE_PRESERVE_ENV when preserving the entire environment.
-Fixes a problem introduced in 1.8.23 where "sudo -i" could not be
-used in conjunction with --preserve-env=VARIABLE. Bug #835
-
-diff -r 797221539242 -r 8ea75ca8fbd2 src/parse_args.c
---- a/src/parse_args.c Tue May 15 16:35:07 2018 -0600
-+++ b/src/parse_args.c Wed May 16 09:10:43 2018 -0600
-@@ -330,14 +330,15 @@
- case 'E':
- /*
- * Optional argument is a comma-separated list of
-- * environment variables to preserve. If not present,
-- * preserve everything.
-+ * environment variables to preserve.
-+ * If not present, preserve everything.
- */
-- if (optarg == NULL)
-+ if (optarg == NULL) {
- sudo_settings[ARG_PRESERVE_ENVIRONMENT].value = "true";
-- else
-+ SET(flags, MODE_PRESERVE_ENV);
-+ } else {
- parse_env_list(&extra_env, optarg);
-- SET(flags, MODE_PRESERVE_ENV);
-+ }
- break;
- case 'e':
- if (mode && mode != MODE_EDIT)
-