summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2018-12-01 10:36:17 +0100
committerNicolas Iooss2018-12-01 10:38:04 +0100
commit1680cc5a92b593289ac7ee04f96ede5b4cf99702 (patch)
treed2ad0699f3c1394257b32f6b70e9b633b9db99bf
parent14251cf772149d3ea0f73c0dd2cd6b8acc036ee6 (diff)
downloadaur-1680cc5a92b593289ac7ee04f96ede5b4cf99702.tar.gz
sudo-selinux 1.8.26-2 update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rw-r--r--bug861-update-fixmdoc-for-bsd-changes.patch131
3 files changed, 142 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c27e9303132..b5d524943d1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sudo-selinux
pkgdesc = Give certain users the ability to run some commands as root - SELinux support
pkgver = 1.8.26
- pkgrel = 1
+ pkgrel = 2
url = https://www.sudo.ws/sudo/
install = sudo.install
arch = x86_64
@@ -12,18 +12,20 @@ pkgbase = sudo-selinux
depends = pam-selinux
depends = libldap
depends = libselinux
- provides = sudo=1.8.26-1
- provides = selinux-sudo=1.8.26-1
+ provides = sudo=1.8.26-2
+ provides = selinux-sudo=1.8.26-2
conflicts = sudo
conflicts = selinux-sudo
backup = etc/sudoers
backup = etc/pam.d/sudo
source = https://www.sudo.ws/sudo/dist/sudo-1.8.26.tar.gz
source = https://www.sudo.ws/sudo/dist/sudo-1.8.26.tar.gz.sig
+ source = bug861-update-fixmdoc-for-bsd-changes.patch
source = sudo.pam
validpgpkeys = 59D1E9CCBA2B376704FDD35BA9F4C021CEA470FB
sha256sums = 40da219a6f0341ccb22d04a98988e27f09b831d2561b14c6154067a49ef3fee2
sha256sums = SKIP
+ sha256sums = 54c6c6667d7de4ec02d5e93e6d859d1069a3b76a0eeb4a6bea5d45472ce8ee26
sha256sums = d1738818070684a5d2c9b26224906aad69a4fea77aabd960fc2675aee2df1fa2
pkgname = sudo-selinux
diff --git a/PKGBUILD b/PKGBUILD
index 6ea890cacc30..4c04845ed454 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
pkgname=sudo-selinux
_sudover=1.8.26
pkgver=${_sudover/p/.p}
-pkgrel=1
+pkgrel=2
pkgdesc="Give certain users the ability to run some commands as root - SELinux support"
arch=('x86_64')
url="https://www.sudo.ws/sudo/"
@@ -24,14 +24,19 @@ provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}"
backup=('etc/sudoers' 'etc/pam.d/sudo')
install=${pkgname/-selinux}.install
source=(https://www.sudo.ws/sudo/dist/${pkgname/-selinux}-$_sudover.tar.gz{,.sig}
+ bug861-update-fixmdoc-for-bsd-changes.patch
sudo.pam)
sha256sums=('40da219a6f0341ccb22d04a98988e27f09b831d2561b14c6154067a49ef3fee2'
'SKIP'
+ '54c6c6667d7de4ec02d5e93e6d859d1069a3b76a0eeb4a6bea5d45472ce8ee26'
'd1738818070684a5d2c9b26224906aad69a4fea77aabd960fc2675aee2df1fa2')
validpgpkeys=('59D1E9CCBA2B376704FDD35BA9F4C021CEA470FB')
prepare() {
cd "$srcdir/${pkgname/-selinux}-$_sudover"
+
+ # https://bugzilla.sudo.ws/show_bug.cgi?id=861
+ patch -Np1 -i ../bug861-update-fixmdoc-for-bsd-changes.patch
}
build() {
diff --git a/bug861-update-fixmdoc-for-bsd-changes.patch b/bug861-update-fixmdoc-for-bsd-changes.patch
new file mode 100644
index 000000000000..5504797cf69e
--- /dev/null
+++ b/bug861-update-fixmdoc-for-bsd-changes.patch
@@ -0,0 +1,131 @@
+
+# HG changeset patch
+# User Todd C. Miller <Todd.Miller@sudo.ws>
+# Date 1542980543 25200
+# Node ID 7ddfb74781a152904ba61cf42f8ce030e5a29554
+# Parent f5531294813905cb6dca04082287c8ae0209da54
+Update fixmdoc.sh to match the BSD -> .Bx changes in the manuals.
+Bug #861
+
+diff -r f55312948139 -r 7ddfb74781a1 doc/fixmdoc.sh
+--- a/doc/fixmdoc.sh Sun Nov 18 07:45:43 2018 -0700
++++ b/doc/fixmdoc.sh Fri Nov 23 06:42:23 2018 -0700
+@@ -35,7 +35,7 @@
+ if [ X"$BAMAN" != X"1" ]; then
+ BA_FLAG='/^.*\n\.Op Fl a Ar type/{;N;/^.*\n\.Ek$/d;};'
+ cat >>"$OUTFILE" <<-'EOF'
+- /^\.It Fl a Ar type/,/BSD authentication\.$/d
++ /^\.It Fl a Ar type/,/\.Bx authentication \.$/d
+ EOF
+ fi
+
+@@ -44,11 +44,11 @@
+ if [ X"$LCMAN" != X"1" ]; then
+ LC_FLAG='/^.*\n\.Op Fl c Ar class/{;N;/^.*\n\.Ek$/d;};'
+ cat >>"$OUTFILE" <<-'EOF'
+- /^\.It Fl c Ar class/,/BSD login classes\.$/d
++ /^\.It Fl c Ar class/,/\.Bx login classes \.$/d
+ /^\.Xr login_cap 3 ,$/d
+- /^BSD login class$/ {
++ /^\.Bx login class$/ {
+ N
+- /^BSD login class\n\.It$/d
++ /^\.Bx login class\n\.It$/d
+ }
+ EOF
+ fi
+@@ -110,7 +110,7 @@
+ # BSD login class
+ if [ X"$LCMAN" != X"1" ]; then
+ cat >>"$OUTFILE" <<-'EOF'
+- /^On BSD systems/,/\.$/d
++ /^\.No On Bx systems/,/\.$/d
+ /^\.It use_loginclass$/,/^by default\./d
+ EOF
+ fi
+diff -r f55312948139 -r 7ddfb74781a1 doc/sudo.mdoc.in
+--- a/doc/sudo.mdoc.in Sun Nov 18 07:45:43 2018 -0700
++++ b/doc/sudo.mdoc.in Fri Nov 23 06:42:23 2018 -0700
+@@ -18,7 +18,7 @@
+ .\" Agency (DARPA) and Air Force Research Laboratory, Air Force
+ .\" Materiel Command, USAF, under agreement number F39502-99-1-0512.
+ .\"
+-.Dd October 27, 2018
++.Dd November 23, 2018
+ .Dt SUDO @mansectsu@
+ .Os Sudo @PACKAGE_VERSION@
+ .Sh NAME
+@@ -173,8 +173,7 @@
+ will exit with an error.
+ .It Fl a Ar type , Fl -auth-type Ns = Ns Ar type
+ Use the specified
+-.Bx
+-authentication
++.Bx authentication
+ .Ar type
+ when validating the user, if allowed by
+ .Pa /etc/login.conf .
+@@ -184,8 +183,7 @@
+ entry in
+ .Pa /etc/login.conf .
+ This option is only available on systems that support
+-.Bx
+-authentication.
++.Bx authentication .
+ .It Fl b , -background
+ Run the given command in the background.
+ Note that it is not possible to use shell job control to manipulate
+@@ -234,8 +232,7 @@
+ settings, such as the umask and environment variables, will
+ be applied, if present.
+ This option is only available on systems with
+-.Bx
+-login classes.
++.Bx login classes .
+ .It Fl E , -preserve-env
+ Indicates to the security policy that the user wishes to
+ preserve their existing environment variables.
+@@ -658,7 +655,7 @@
+ .It
+ Solaris privileges
+ .It
+-.Bx No login class
++.Bx login class
+ .It
+ scheduling priority (aka nice value)
+ .El
+diff -r f55312948139 -r 7ddfb74781a1 doc/sudoers.mdoc.in
+--- a/doc/sudoers.mdoc.in Sun Nov 18 07:45:43 2018 -0700
++++ b/doc/sudoers.mdoc.in Fri Nov 23 06:42:23 2018 -0700
+@@ -18,7 +18,7 @@
+ .\" Agency (DARPA) and Air Force Research Laboratory, Air Force
+ .\" Materiel Command, USAF, under agreement number F39502-99-1-0512.
+ .\"
+-.Dd October 27, 2018
++.Dd November 23, 2018
+ .Dt SUDOERS @mansectform@
+ .Os Sudo @PACKAGE_VERSION@
+ .Sh NAME
+@@ -282,9 +282,7 @@
+ contents of the
+ .Pa /etc/environment
+ file.
+-On
+-.Bx
+-systems, if the
++.No On Bx systems , if the
+ .Em use_loginclass
+ option is enabled, the environment is initialized
+ based on the
+@@ -472,9 +470,7 @@
+ .Pa /etc/environment
+ are also
+ included.
+-On
+-.Bx
+-systems, if the
++.No On Bx systems , if the
+ .Em use_loginclass
+ flag is
+ enabled, the
+